Console Window Startup?


#1

Why when I start Atom, does it only start a debugging / console window ?


#2
  1. What does the console error say?
  2. Does this happen when you open Atom from the command line with atom --safe?
  3. Does this happen when you close Atom, rename the .atom folder, and open it again?

#3

I can’t even say I have begun to use Atom, I’ve only opened it a few times as I need to begin to use it.

The error says it’s not a valid Win32 application in the Console window ?

Opening Atom from the command line using the command you mentioned works. Renaming the Atom folder causes the same problem, console window pops up with the error mentioned previously.


#4

What community packages do you have installed?

Can you screenshot it?


#5

What do you mean by community package ? :slight_smile:


#6

Community packages are packages created by Atom’s users. Core packages are maintained by the dev team. You can use the command apm ls to generate a list of the packages you have installed.


#7

The command apm 1s just produces;

INFO: Could not find files for the given pattern(s).
Unrecognized command: 1s


#8

apm ls, not apm 1s. You can also just copy and paste what I wrote and you’ll find that I wrote the letter l.


#9

I hope this helps ?

Built-in Atom Packages (89)
├── atom-dark-syntax@0.27.0
├── atom-dark-ui@0.52.0
├── atom-light-syntax@0.28.0
├── atom-light-ui@0.45.0
├── base16-tomorrow-dark-theme@1.3.0
├── base16-tomorrow-light-theme@1.3.0
├── one-dark-ui@1.6.2
├── one-light-ui@1.6.2
├── one-dark-syntax@1.5.0
├── one-light-syntax@1.5.0
├── solarized-dark-syntax@1.0.5
├── solarized-light-syntax@1.0.5
├── about@1.7.0
├── archive-view@0.62.0
├── autocomplete-atom-api@0.10.0
├── autocomplete-css@0.13.1
├── autocomplete-html@0.7.2
├── autocomplete-plus@2.31.4
├── autocomplete-snippets@1.11.0
├── autoflow@0.27.0
├── autosave@0.23.1
├── background-tips@0.26.1
├── bookmarks@0.42.0
├── bracket-matcher@0.82.2
├── command-palette@0.39.0
├── deprecation-cop@0.54.1
├── dev-live-reload@0.47.0
├── encoding-selector@0.22.0
├── exception-reporting@0.40.0
├── find-and-replace@0.202.2
├── fuzzy-finder@1.4.0
├── git-diff@1.1.0
├── go-to-line@0.31.0
├── grammar-selector@0.48.2
├── image-view@0.60.0
├── incompatible-packages@0.26.1
├── keybinding-resolver@0.35.0
├── line-ending-selector@0.5.0
├── link@0.31.2
├── markdown-preview@0.158.8
├── metrics@1.1.2
├── notifications@0.65.1
├── open-on-github@1.2.1
├── package-generator@1.0.1
├── settings-view@0.243.1
├── snippets@1.0.4
├── spell-check@0.68.4
├── status-bar@1.4.1
├── styleguide@0.47.2
├── symbols-view@0.113.1
├── tabs@0.103.0
├── timecop@0.33.2
├── tree-view@0.210.0
├── update-package-dependencies@0.10.0
├── welcome@0.35.1
├── whitespace@0.35.0
├── wrap-guide@0.38.2
├── language-c@0.54.0
├── language-clojure@0.22.1
├── language-coffee-script@0.48.0
├── language-csharp@0.13.0
├── language-css@0.40.1
├── language-gfm@0.88.0
├── language-git@0.15.0
├── language-go@0.43.0
├── language-html@0.46.1
├── language-hyperlink@0.16.1
├── language-java@0.24.0
├── language-javascript@0.122.0
├── language-json@0.18.3
├── language-less@0.29.6
├── language-make@0.22.2
├── language-mustache@0.13.0
├── language-objective-c@0.15.1
├── language-perl@0.37.0
├── language-php@0.37.3
├── language-property-list@0.8.0
├── language-python@0.45.1
├── language-ruby@0.70.2
├── language-ruby-on-rails@0.25.1
├── language-sass@0.57.0
├── language-shellscript@0.23.0
├── language-source@0.9.0
├── language-sql@0.25.0
├── language-text@0.7.1
├── language-todo@0.29.1
├── language-toml@0.18.1
├── language-xml@0.34.12
└── language-yaml@0.27.1


#10

This is puzzling. You say that you’ve opened Atom successfully in the past and now it’s only working in safe mode. Safe mode is mostly used to isolate whether a package is causing the problem, but you say that you don’t have any. On GitHub, there are a couple of closed issues about your error message where the culprit there was building Atom from source.

This one is the most like yours (it cites pathwatcher.node) and it was resolved by just trying again:

You could try downloading a new installer and deleting the contents of AppData\Local\atom.


#11

I don’t run Atom in safe mode regularly I only ran Atom in safe mode after your suggestion. I run Atom by the executable and only the executable.
I successfully started Atom once or twice after a fresh install; thereafter Atom doesn’t start only a console Window as mentions open, doesn’t make sense.

Isn’t there any way to fix this, if it should so happen again ? Downloading a new installer doesn’t guarantee that this issue may not arise again, if a solution could be had and this would occur again, then I would know of the fix and it would not be a problem as it currently stands.


#12

It was probably something messed up in Atom’s directory after a previous update, but there’s no way to offer a definite fix without knowing what the issue is. Right now, I’m just pretty sure what was wrong, and the fact that it’s fixed fits with my hypothesis, but I can’t point to something that definitely caused it.

If it happens again, check in AppData\Local\atom to see if the latest version folder is a recent addition, which would suggest that the update caused it.


#13

There are three versions within AppData\Local\atom

  • app-1.12.1
  • app-1.12.2
  • app-1.12.4
  • app-1.12.5

I assume I should delete all but app-1.12.5 folders ?


#14

If it works currently, you don’t have to delete anything. The old folders aren’t necessary and they mostly get emptied out when a new version is installed…


#15

It doesn’t work, when strictly executing atom.exe; that is why I asked if I should delete any of the version folders ?


#16

If it’s not working, then try deleting all the contents of AppData/Local/atom and reinstall.


#17

A re-install solved the problem :slight_smile:

I hope this issue doesn’t surface anytime soon. That issue being whereas atom doesn’t start with the default executable atom.exe. :grin: