Configure settings for atom-ctags


#1

Hello. How do I set a setting for atom-ctags? In its page: https://atom.io/packages/atom-ctags says:

‘cmdArgs’ setting, add specified ctag command args like: --exclude=lib --exclude=*.js

I need to set the ‘cmdArgs’ setting, but I dont know where is the setting file for atom-ctags. How can I achieve it?

Thanks.


#2

It’s a config setting, so you’d add the arguments in the settings view for the package (Settings -> Packages -> Atom Ctags).


#3

I am having the same issue, but the package atom-ctags does not have any settings options


#4

The version I just now installed does. If you don’t see a Settings button on the package card, you can click anywhere on the card that isn’t a link to get there.


#5

thanks @DamnedScholar,

Yes, found it eventually. I also had to set the time out to 30 sec to work.

The exclude works I think, but creates a huge file (15Mb) which crashes the atom window when it reloads.

Maybe I am missing something, I am trying to create ctags for a WordPress project,excluding the WordPress core files, but including the plugins and theme I am using. It works fine, and I am now able to go to declarations, however, on restart the atom window for that particular project crashes.

Is there an Atom settings for memory allocation that I need to increase so the window does not crash on restart?


#6

There is not, as far as I know. Does Atom crash when you open that particular project in safe mode? (From the command line, atom --safe path/to/project.) Are there any particularly long files open, or any minified files open?

I don’t have any experience with atom-ctags, so I have no idea under what circumstances it might be implicated in a crash.


#7

I’ll try in safe mode to see.

However, I tried different projects, each time with creating ctags which created a large file (sometimes upto 75Mb) in the root of the root of the Project Folder. As soon as I deleted that file (.tags) the project window would load just fine.


#8

It sounds like Atom and the package might have a problem with one another. You could bring it up at the package repo.


#9

Ok, just realised that this issue is around since atom v1.8.0 and reported in issues 147 & 157