*Completely* frameless/transparent Electron Browser Window

Not sure if this is caused my bug, electron bug, or is intended behavior. I would like to have a completely frameless and transparent Browser Window. It is very close but there is still a 1px line that appears to be the top of the frame. Here are the options I pass to the window:

const opts = {
    transparent: true,
    frame: false,
    width: 400,
    backgroundColor: "#00ffffff",
    hasShadow: false,
    alwaysOnTop: true,
    resizable: false,
    titleBarStyle: "none",
    webPreferences: {
      nodeIntegration: true,
    },
  };

And this is the result:

Any tips?

That shadow might be caused by your OS.