Compile error pop up duration is very short


#1

Is there anyway to make the pop up screen of the compiler error shows longer?
I cannot read anything. Goes off too quick. Help!


#2

Hi Andrew - how are you doing?..

Please consider telling the guys and gals which Package you are using.
My very wild guess is that this is where the answer is going to be.

Cheers.


#3

Package meaning the theme? Or the compiler?


#4

Atom is a text editor.
Add-on packages extends its functionality.

In this case we are not referring to how it looks (theme) but how it works:
(HINT: script is such a package that gives Atom some IDE abilities.)

Source code -> Atom -> Package -> Compiler -> Execution
                          ↑
                          ?


#5

I think I dont really install packages… but i installed this compiler
with xcode comman line…


#6

Hello.

I see you have logged a request at the package’s project - very good.
That is the best place to make your request.

The code of the atom-gpp-compiler package is open source - you can view it here: [LINK]. It would be possible to customize your experience if you know how and where. Possibly here - https://github.com/kriscross07/atom-gpp-compiler/blob/master/index.js#L293

After a quick look I see that there are several customizing options available.

The view that you showed in the picture above, please click on the settings button. There are options to view compiler messages in a text file as well as in the console. - - I hope I understood this correctly from the code.

Atom has an built-in console that you can reach:

Designers normally use this console to show system messages. Perhaps you may find some of the messages you seek there. Beyond possible messages here, the console will not be helpful for compiling and running C code.

That is about all I can try to help with - good luck.
- Dan Padric


#7

So i can get the error messages there?


#8

The look of the notifications is determined by the theme in use. The default themes allow scrolling inside notifications, so you could either request that for the theme in use or submit a PR yourself.

@andrewtwirling Are you using atom-material-ui or some other Material theme?


#9

I use some other theme too…


#10

But it doest really have any settings


#11


#12

I misread your initial post, I thought you were talking about dimension, not time. So that’s definitely a request for the author of atom-gpp-compiler. In my own build packages I have added an option, whether to auto-close the notification or not. I’d ask the author of that package to do the same.


#13

I thought this was the only compiler for c++/c. I started learning the basic only so… i am a bit noob :smiley:


#14

I haven’t tested it, but this should allow you to control whether notifications get dismissed or not:

(this should replace ~/.atom/packages/gpp-compiler/index.js)


#15

Where should I paster / install(??) this exactly …


#16

i found this one… but didn’t work


#17

@idleberg: Thank you for helping!!


@medrewb:
Hi Andrew,

[ALTERNATIVE]

First things first - a friend in the office has recently started learning Java and C++. He could not get Atom to function as he wanted. He used another free code editor: Visual Studio Code from Microsoft. It is the half brother of Atom. Here is a C++ related description: C++ in VSCode.

Let this be your fall-back if you do not get results you hope for. Do know however that it is not a MUST to compile within the text editor and the package you selected is not the only one available.



[WITH WHAT YOU HAVE]

I do not know if the messages appear in the console or in the file compiling_error.txt in the correct way. It has been 20years since I touched C++. You have to test yourself.

Please see on your own what effects are there of each of the setting adjustments. Search for a compiling_error.txt file.



[CHANGE TO PACKAGE]

Andrew - @idleberg is a skilled programmer.
You are lucky to have him contribute.
Please consider saying ‘Thank you’ for his time and effort.

The changes he did should resolve your problems. The changes he contributed is listed commit #1 and commit #2. It is even better than the request you linked to Compile Error message closes too rapidly as there is one added configuration settings.

The master of the package might not respond soon. I am trying to walk you through changing the package.


1. Get the changed index.js

First download the file provided by @idleberg. Make sure to get the latest file he linked to. Store this on your computer where you know where it is.


2. Pin the version number of the package.

I recommend to do this first before continuing. This ensures that the changes you make on your PC is going to stay that way until you decide otherwise.




3. Working with the configuration folder

I have never worked on a MAC (I use Windows), so I will have to talk you through using the functions within Atom. Some things will look and work different.

Open the configuration folder in a second Atom session.

Select the package sub folder. Search for your package atom-gpp-compiler and then the file index.js. The picture below shows another package and file, so follow the instructions above. Next: duplicate the file - something like index_js.backup.


PIC004

Keep the backup if things go wrong (which I doubt highly).


4. Open the file index.js in ‘file explorer’

PIC005
Replace the original index.js with the file you got in step 1.
(How is right click on a Mac?)
(Step 3 can be done within this step instead.)


5. Restart Atom

  • Close all open programs… specifically all Atom sessions.
  • Then re-open Atom.


6. Configure the atom-gpp-compiler package

Check that all configurations are as they should be for the package.


7. Test

Test if you have the required result. Please let us know.


I hope this is of value to you.
Cheers.


#19

Its working… WOW thanks @danPadric and Thanks Sir @idleberg for writing the Code for me…

Thank you . so much … :heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes::heart_eyes:


#20

54 PM

Here is a screenshot with the X button :smiley: Thanks again.


#21

Andrew - sending a :smile: back to you.
It is great news to hear you have what you wanted.

Please consider to pay-it-forward (what is that? per wikipedia).
You can do so by helping someone else or simply sharing your experiences here.

Cheers.
- Dan Padric