Compile error for atom editor on linux


#1

I am trying to compile atom editor for the following configuration.

Node: v5.9.1
npm: v2.13.3

The machine is running Linux 3.0.52, python version 2.7.2
I get the following error.

make: *** No rule to make target `|', 
needed by `Release/obj.target/minidump_stackwalk/deps/breakpad/src/processor/exploitability.o'.  Stop.

Additional messages at the end of the log are attached

npm ERR! minidump@0.9.0 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the minidump@0.9.0 install script ‘node-gyp rebuild’.
npm ERR! This is most likely a problem with the minidump package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls minidump
npm ERR! There is likely additional logging output above.

I tried compile the stable source atom-1.6.1 as well as atom-1.7.0-beta4. I get the exact same error.
gcc version is 4.1.2

Not entirely sure how to start debugging because the log is not useful in providing the directory of the error…

Any help is appreciated…

Wish


#2

Did you follow the build instructions for your particular flavor of Linux?


#3

OOps… should have mentioned that in my original post.

I am using the instructions you pointed to.
In order to build I use :slight_smile:
script/build

Wish


#4

What flavor of Linux are you using?