Colon is not working when coding


#1

New to Atom. Love it, but I have a problem.

When coding, I am not able to use the keycombination for colon ( : ).

I am using basic packages, and linter for css, html, js, php and XML.

Any advice is welcome :slight_smile:


Cannot type colon in html/php files
#2

Maybe I don’t understand, but what key combination is required to type a colon? Isn’t that a normal character?

In any case is this an international keyboard? Have you tried running Atom in safe mode from the command line? Type atom --safe.


#3

You may be running into this:


#4

I have a norwegian keyboard. In order to get colon, I need to press this combination: Shift + dot


#5

I forgot to mention that I am using a norwegian keyboard.

In order to get colon, I need to press this combination: Shift + dot (.) to get colon.


#6

Hello,

I had the same problem and i just installed the “keyboard-localization package” and it works again! :slight_smile: Thanks for the help!


#7

I solved the problem in the end. Disabled all packages and activated them one by one. The package Autoclose-HTML was apparently not working properly. Thanks for all advices and tipses everyone :slight_smile:


#8

The bug is still in Autoclose-HTML.