Close buttons of tabs lost


#1

Hi guys, this occurred after I modify Ubuntu’s Royal Theme, through Unity Tweak Tool and editing some lines in its source codes . . . .

But I don’t remember doing anything with the preference of Atom. When I reverted back to the state of the theme where Atom did not have this bug, it still occurred. :tired_face:

Any ideas?

PS. Also the tabs in this dark-flat-ui theme (@olmokramer’s theme) is auto stretched and auto-sized in length whenever I create a new tab, but in this bug, it’s creating standard lengths of this tab. :persevere:


#2

What version of Atom and OS are you using? Did you try disabling the theme, or even uninstall it and reinstall it again?


#4

Atom v. 0.175.0 and Ubuntu 14.10. I haven’t yet, but I’ll try. But what I noticed is it also affected the core themes, the Atom Dark and Atom Light. No close buttons. :disappointed:


#6

Close buttons still lost. :persevere:


#7

Turns out the close buttons use unicode character \f081. Did you by any chance change your system font?


#9

Umm, didn’t remember changing anything related to that. Only the color schemes in the Royal Theme.
So, how do I solve this bug?


#10

I’m a bit at a loss here… You can debug atom with the Chromium DevTools: press Ctrl-Shift-I, click the maginfying glass and click on a tab. Is the Icon still there in the HTML but just doesn’t show? Are there any conflicting rules on the .close-icon in the tab?
Also, did you try restarting Atom between uninstalling the themes and installing them again? Did you build Atom yourself or did you download the .deb from http://atom.io? Or are you using the ppa (if so, you shouldn’t use it, it has been known to cause problems)?


#11

Output:

Umm, I dunno where to go from here already. Hehe. :stuck_out_tongue_winking_eye:
Have you noticed it too? The tab length is set already, like limited to a certain length only (same goes if a new tab opens). It isn’t like this from your theme right?


#12

I . . . . . forgot already. I think its the latter I guess? Or a sudo apt-get command? I tried restarting, disabling and reinstalling. I think reinstalling Atom would be my last resort. :weary:


#13

Could you scroll down all the way in the bottom-right panel (with the orange/yellow/green/blue rectangle), then expand the width property (if possible). It will tell you the css rule that sets the tab’s width.


#14

What is the output of apt-cache showpkg atom from command line, specifically the versions part?


#15

Like this?


#16

This:


#17

Yeah, you’ve installed it via ppa. Please try the following:

  • mv ~/.atom ~/.atom.bak
  • sudo apt-get remove atom
  • in the /etc/apt/sources.list.d/ directory, find a file with webupd8 and atom in the name and sudo rm them
  • sudo apt-get update
  • download the .deb from atom.io
  • sudo dpkg -i /path/to/atom-amd64.deb
  • mv ~/.atom.bak/* ~/.atom

This has a downside though, you won’t have automatic updates via apt-get upgrade


#18

This post is in case you missed the edit above to sudo apt-get update after deleting the files in /etc/apt/sources.list.d


#19

Can you reproduce the issue after closing all instances of Atom and then starting Atom using the command atom --safe?


#20

Nvm that, it was already fixed after reinstalling it through @olmokramer’s advice. Thanks for that though! :smile:


#21

Umm, sorry for the late reply, I reached the maximum number the other day, but, what could happen it I didn’t sudo apt-get update it?
And also, mv ~/.atom.bak/* ~/.atom causes an error saying that .atom is not a directory or something. But my Atom works fine right now?


#22

If it’s fixed it’s fixed, right? :smile:

The sudo apt-get update was just to make sure the packages from the ppa are no longer available through apt-get. Not actually required I think, but just to be absolutely sure you didn’t install that one again :smile:

The mv ~/.atom.bak/* ~/.atom is to “recover” your old config files and packages… If ~/.atom doesn’t exist you can always create it yourself, or maybe Atom has to be run in order to create the directory. Or if you don’t mind losing your old config, you can just delete ~/.atom.bak.


#23

Just as what you said. Hahaha. Thanks again! :grin: