Character Encoding


Just getting started with atom and I’ve been writing a markdown file. I’ve used the term ‘cliché’, which in my file renders as clich�. Do I need to do anything special for character encoding so this will render correctly?


In the bottom left corner there’s a few indicator / selector. Clicking the encoding (here UTF-8) and changing it might display character correctly. For example windows 1252 is what some other editor use by default on windows.


Appreciate the reply! I had them all set to auto, and toggling through them didn’t really resolve any issue (just changed how it rendered that character).

Maybe what I’ve detected is a bug, I originally spelled it as ‘cliche’, without the é character, then I used the spelling correction and that’s when the � character was introduced.


Character encodings other than UTF-8 are a pain. And character encodings period are hard to debug. If you select UTF-8 as the character encoding, what does it show? Also, if you can install the hex package and either take a screenshot of what the hex package shows or tell us what the actual binary value of the é character is, that would help.


Atom use OS spelling correction library when available. What OS and language setting do you use?

Maybe what I’ve detected is a bug

If spelling library and Atom editor use different encoding, that’s possible.


@jeancroy: In Fedora, can I use google spelling corrections by chance? I believe I had google-spell-check set up in sublime.

@leedohm: Document was already set to UTF-8, the character is introduced when I right click and ask for spell check suggestions (its the first time I see the character). Is there a package for taking screenshots within atom?


No, there is not.

Could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?


I beleive atom use this

So in you case that default to Hunspell

It seems there’s some particularity to setup encoding in hunspell, i’m not sure if it’s done in node-spellchecker.


@leedohm: 1.3.2 (installed from via the rpm method). I’m in Fedora 23.