Changing syntax theme doesn't change text color


#1

I’m a student who has been using Atom for a few weeks now for ruby homework and I’m definitely enjoying it.

Today I figured I’d explore some features a little more, but when I tried to change the syntax theme I found that the text colors stay the same. Or maybe more specifically the background color changes and the text color seems to be a slightly different version of the same set of colors? Almost like the background color is dictating the shade of the same color theme.

Now I know different themes are supposed to be radically different sets of colors so this seems like its working incorrectly. Here’s what I tried (im on OS X)

  • Basic restarting of program/computer and installing of different themes
  • Complete reinstall of Atom including deletion of all appropriate hidden folders as found in a different Atom support thread

since the problem remains after a complete reinstall im totally baffled as to what could be going wrong. when i start up Atom i get this in the console but im not sure if theres any relation:

index.js:52 Window load time: 362ms
/Applications/Atom.app/Contents/Resources/app.asar/node_modules/space-pen/lib/space-pen.js:452 /deep/ combinator is deprecated. See https://www.chromestatus.com/features/6750456638341120 for more details.
/Users/distiller/atom/out/app/src/text-editor-component.coffee:978 ::shadow pseudo-element is deprecated. See https://www.chromestatus.com/features/6750456638341120 for more details.

any help would be greatly appreciated. I’d really love to try out some syntax themes and I feel totally lost on this


#2

small extra note: the theme I think its “stuck” looks to be “one dark”

again the background color Does Change


#3

Which themes are you trying, exactly? Can you screenshot the before and after? You can also open the developer tools View -> Developer -> Toggle Dev Tools and observe exactly what CSS is being displayed, so you can see if the colors visible to you match the ones coded into the themes.


#4

Different themes aren’t necessarily supposed to be radically different sets of colors. Your experience in this case is highly dependent on which two themes you’re selecting between.

I also can’t reproduce this using Atom v1.13.0-dev-11f8d9e on Mac OS X 10.12. Here’s a screenshot of some Elixir code I’m working with in my default One Light syntax theme:

And here’s a screenshot using the Solarized Light syntax theme:

So the stylesheets are changing though perhaps not in obvious ways with the two themes you’re switching between.