Changing invisibles characters


#1

I want to customize the characters used for the various invisibles. I attempted to change them in config.cson like so:

'editor':
  'fontFamily': 'Source Code Pro'
  'fontSize': 16
  'invisibles':
    'cr': '↩'
    'eol': ''
    'space': '·'
    'tab': '⇥'

And this works fine until I open the Settings panel cmd+,. As soon as I do, the invisibles setting is replaced with:

'editor':
  'fontFamily': 'Source Code Pro'
  'fontSize': 16
  'invisibles': '[object Object]'

Is there a way around this?


#2

Hi,

This is a bug in the settings view, I’ve opened up a PR here: https://github.com/atom/settings-view/pull/52

This is just an initial implementation to prevent the behavior you are seeing where the object is being corrupted.

We will add a more robust UI for editing nested objects in the future.


Settings Object is not kept when viewed in preferences
#3

Just tried it in v0.65 … works great! Thanks! :clap:


#4

Doesn’t work for me in v0.65 :cry:


#5

What isn’t working?

You may have to reset the values initially if they already were corrupted to “[object Object]” in previous releases.


#6

When I edit my config.cson file to include the below snippet:

'invisibles':
  'cr': '↩'
  'eol': ''
  'space': '·'
  'tab': '⇥'

Save and then do a cmd-, it changes it to 'invisibles': '[object Object]'

This is still going on in 0.67.0.