Change syntax highlighting


#1

Hi,

today i was changing highlighting syntax on file, when clicking at one i want to, whole “select box” from bottom-right of editor disappear. Restart atom didnt help. Now i dont see what syntax highlighting i have selected. Can i bring it back?

Thanks for help.


#2

Can you include a screenshot of your editor window? Atom’s built-in status bar widgets can’t be turned off or torn off, so there must be something else at work here? Also, have you tried reproducing the problem in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#3

Launch Atom in safe mode didn’t help. Here is screen of my window


#4

You must have disabled the grammar-selector package. You can find it in the Settings View and re-enable it by clicking here:


#5

I do not remember dissabling that plugin, but it is disabled. Enabling helps, thanks a lot.