Change font permanently...atom keeps updating on restart


#1

So I want my font to be different that the packaged atom font but if I change it in styles.less it only works until I restart. This is because to get it to work in the first place I have to add

@font-face {
  font-family: code;
  font-style: regular;
  src: url('fonts/SourceCodePro.ttf');
}

to styles.less and I have to go into the actual atom package and add a ‘font’ folder as it treats it as a resource and won’t take the absolute position on my machine. When I restart atom updates its resources and deletes my changes Is there anyway around this?


#2

using file:///Users/you/fonts/SourceCodePro.ttf as the path should work


#3

Why not just change it in the Editor settings?


#4

I assume this requires the font to be pre-installed somewhere?

I feel very stupid, but what if I’m on Windows, have installed the ttf files in the standard Windows way, but when I add it to the settings as you suggest, I get some standard bullshit font, which I assume is what it defaults to if the provided one cannot be found?



#5

If you just want to use the normal version of Source Code Pro then you can just use “Source Code Pro” in the Font Family setting. The weird spacing is a trick that, as far as I’ve seen, only works on OS X … and is only useful for different font weights than the normal.

The font just has to be available as a system font.


#6

And that works perfectly. Thanks @leedohm!


#7

Try the Fonts Package: https://atom.io/packages/fonts