Change CWD in sub folders


#1

Starting atom from the shell (atom .) sets my CWD to the directory where I open atom from.
All good, but I usually open atom in the directory where I have lots of projects.
So I start in /Users/me/bitbucket, but in bitbucket, I keep allow my current work.
When move down to project1 or project2, how do I get the CWD to change so that I can executes scirpts?


#2

What package are you using to execute scripts?


#3

script 3.17.3.
By default it takes the path used when you start with atom from the command line.
But if you change to another folder …


#4

You can manually control the CWD used by script using the script:run-options command (this can be found under Packages -> Script -> Configure Script or shift-cmd-i on Mac).


#5

If I define my script as Python (for example) in the lower right hand corner and the hard code the current directory into the configuration, then it works.

But when I use {FILE_ACTIVE_PATH} as suggested in the documentation, then it won’t even run python.
I had more screen shots, but I can only upload one as a new user.


#6

I don’t know enough about the package to troubleshoot this.

I had more screen shots, but I can only upload one as a new user.

Imgur is a very useful service for cases like this.


#7

Thanx … good idea …


Here are the screen shots


#8

I would suggest the package process-palette, which is similar but with more options and I know for a fact that playing with the CWD works because I’ve done it.


#9

Thanks. process-palette is much easier to use.