Can't use atom_runner_master or atom_script_master


#1

i’m a windows 7 user, i don’t have Internet in my pc , so i downloaded atom_runner_master and atom_script_master manually with my phone than sent them to the pc, and extracted theme to c:\users\PC.atom\packages
the problem is when i want to run a programe using the script package an error pops up: "cannot find module ‘uuid’ "
and with using atom_runner an error pops up: "cannot find module ‘atom-space-pen-views’ "
anyone can help pls ?


#2

Atom packages have numerous dependencies, so you’ll need to install them on the computer with an internet connection.


#3

thx Aerijo for replying,
i have another problem too, when i click the “install” button in the settings, an error pops up so i can’t install packages from atom directly , i took a picture of it.


#4

Unless you make that screenshot available to us, there’s not much we can do to help you.


#5


#6

It’s possible that Atom didn’t install properly. I would try reinstalling it. Since all of your settings are stored in the .atom/ folder, you will not lose anything.


#7

i’v done that before but no good, guess i have a problem in my pc


#8

What happens when you go to the GitHub releases page and download atom-x64-windows.zip or atom-windows.zip (as of right now, you should download version 1.26.0), then unzip the contents to a folder, and open the executable inside?