Can't update packages: ETIMEDOUT


#1

Hello,

Atom has been failing to update my packages for a while, so I thought I’d post on here to see if anyone can help. If I run apm update, I get this:

Request for package information failed: connect ETIMEDOUT 75.101.145.225:443

…yet atom still tells me that there are 6 updates available on in the status bar.

  • Atom version: 1.13.0
  • OS version: Windows 10

Not able to find git-clone in package installer
#2

What happens if you try to update one package at a time?


#3

Good idea!

Unfortunately, I can’t see a list of which packages need updating as I get the same error if I check for updates through the user interface by going to the Updates tab of the Settings window.


#4

I assume that you can run apm list and get the list of packages you have installed and then go through them one at a time. It isn’t ideal, but it should get you there if you can update one package at a time.


#5

Ah ok! Yeah, apm list works. I didn’t know about that command. I haven’t used the apm command line tool all that much :slight_smile:

I assume to update a package it’s apm update <package-name>?

Edit: Yep, apm update <package-name> looks like the right command.


#6

Yeah, it looks like I can update one-at-a-time. That’s odd. It’s really inconvenient though. Is there any way to bring back updating everything at once?


#7

There is an open Issue for this on https://github.com/atom/apm, I believe. I’ve got to get ready to conduct an interview or I would find it for you :frowning:


#8

Ah ok! Thanks for that. I’ll follow that issue then.

It’s issue #641 I think. Link: https://github.com/atom/apm/issues/641


#9

Yes, that’s the one … thanks for tracking that down :grinning: