Can't update any packages [Solved]


#1

As of 1.4.1 I can’t update any packages.

I get this error:

Packages that depend on modules that contain C/C++ code will fail to install.
Read here for instructions on installing Python and Visual Studio.
Run apm install --check after installing to test compiling a native module.

The read here link doesn’t link to anything but the main Atom documentation. These packages all worked and installed/updated previously without any issue till now.

If I click to show output it says:

gyp info it worked if it ends with ok
gyp info using node-gyp@2.0.2
gyp info using node@0.10.40 | win32 | ia32
gyp http GET https://atom.io/download/atom-shell/v0.34.5/node-v0.34.5.tar.gz
gyp WARN install got an error, rolling back install
gyp


#2

Have you tried this?


#3

Yeah, I get the same error:

gyp info it worked if it ends with ok
gyp info using node-gyp@2.0.2
gyp info using node@0.10.40 | win32 | ia32
gyp http GET https://atom.io/download/atom-shell/v0.34.5/node-v0.34.5.tar.gz
gyp WARN install got an error, rolling back install
gyp

Should I just… reinstall node? Or something?

Haven’t uninstalled anything else on this box so not sure what else could have changed.


#4

Wouldn’t hurt, but the symptoms seem to point to a problem in your visual studio or python setup. Try installing a node module that requires gyp. If that fails then you know it has nothing to do with atom.


#5

The read here link should point to the Requirements section here:

I’m pretty sure there is a bug open on this already. I just can’t find it at the moment :frowning:


#6

Wow. Guess I’ve never had either Visual Studio 2013 or Python installed. Not sure how I’ve been using Atom uninterrupted and updating these same packages for so long, lol.

Installing both now… we’ll see if that fixes it.


#7

Some packages start out without native components and add them later. Things would install and update just fine without native components.


#8

Weird that all 5 packages I use would all add the same requirements at the same time…

  1. Installed Github Desktop and logged in with an account
  2. Installed Python, the exe is at %SystemDrive%\Python27\
  3. Installed Visual Studio 2013 + Update 5 Community Edition
  4. Ran a repair install on node.js

Same error, can’t update any of my packages:

gyp info it worked if it ends with ok
gyp info using node-gyp@2.0.2
gyp info using node@0.10.40 | win32 | ia32
gyp http GET https://atom.io/download/atom-shell/v0.34.5/node-v0.34.5.tar.gz
gyp WARN install got an error, rolling back install
gyp

Any chance to see a bigger/better log of what went wrong somewhere?