Can't undo .gitignore effects


#1

When I put something in .gitignore the file disappears from my treeview even though I have exclude vcs ignored paths turned off. What’s worse is that when .gitignore is changed to not ignore a file the file is still hidden in the tree view.

I put a gitignore with ** in my lib folder as a test and then removed it and now I’m screwed. I can’t see any files in there. Does someone know where this is stored so I can clear it?

Edit: I also tried safe mode with no luck.


#2

I just discovered that the tree-view package has its own setting to hide vcs ignored files which fixed part of the problem. The stickiness problem is still there.

Why is this setting in two places? What does the one in the general settings page do?

Edit: The stickiness problem was my fault. So everything works now that I found the correct setting.


#3

Duplicate of:

The one in the general settings page is used by the Fuzzy Finder for things like the quick opening of files. The two use-cases are and should be distinct.