Cant type in language C


#1

Every time I press any key I get:

Uncaught TypeError: Cannot read property 'c' of undefined /Applications/Atom.app/Contents/Resources/app/node_modules/text-buffer/lib/history.js:99

I also can’t report the bug as I get:

SyntaxError: Unexpected end of input
    at Object.parse (native)
    at window.onload (file:///Applications/Atom.app/Contents/Resources/app/static/index.js:6:29) index.js:29window.onload

I re-downloaded and removed ~/.atom file.
Thank you in advance for help.

Edit: The issue will disappear if I go and edit another file that is not .cpp and not in the same folder. But it will appear if I close and open Atom again and attempt to edit the .cpp first.

Edit: Now it works. I don’t understand this.


#2

I get the same error with .c files. By the way, the editor detects .c files as C++ and .m files as Objective-C++. Enter works fine inside functions in C++ and inside @interface and @implementation in Objective-C++. Changing type to “C” or “Objective-C” in bottom bar fixes the error.


#3

Looks like this is a duplicate issue of


#4

It is. Please can you close this one?


#5