Can't set up Java Path correctly

Hey I’m new to atom and don’t know how to use it properly yet. I was trying to use java in atom. I’ve installed the following packages : ide-java, atom-ide-ui, script. I have set the path java path in the editor but every time I open atom, a popup says to set the java path correctly. I tried looking answers online but couldn’t find anything. I’ve tried it with other IDE’s and worked finely. Also the java code I wrote in atom does not compile. I’ll be really glad If you can help me out someway.

this is the path I set up and the the error massage above keeps popping up

That looks like two paths; it’s only asking for one.

2 Likes

Bear in mind, you are in Windows and I am in Ubuntu.
Paths will differ.
In a command terminal I run the command

echo $JAVA_HOME

and I see …

/usr/lib/jvm/java-1.8.0-openjdk-amd64/jre

and I can paste this into the Settings field.

If $JAVA_HOME is not set, you can set that first in environment vars then apply path in Atom.

1 Like

I tried it with one path too. It didn’t work

It worked! I hadn’t set up the JAVA_HOME path. Thanks alot!