Can't push using git-plus


#1

Everything works fine but it turnes out I can’t push anything to my repo:

Using Windows… Git is in my PATH.


Git-Plus, how do you sync to remote?
#2

Did you ever find the answer to this? I’m getting the exact same error message.


#3

Have you configured your ~/.gitconfig file with your username and email as stated in the package documentation?


#4

Do you mean typing into the command prompt:

git config --global user.email "your_email@example.com"
git config --global user.name “Billy Everyteen”

then checking to make sure they took by typing:
git config --global user.name
git config --global user.email

? I read the package documentation and searched for gitconfig but couldn’t find anything of the sort.

This is the error I get:


#5

What are you doing to get to this error?

It would be in your user folder.


#6

Im just trying to push the commit I’ve made, it says “pushing” then this error shows up for 2 seconds. I’ve now testing this on my laptop too, installing github for windows for the first time, and atom for the first time, after adding the environment variable that’s needed to make anything work, I can add, commit, but then push gives this error.

I downloaded sublime text 3 and installed a git package for it, and it also gave me this exact same error.

This has to be a problem with git for windows, otherwise how am I getting the exact same error on two different computers, and in two different editors that each have their own git packages?

I finally found a gitconfig file, but it was located in:

C:\Users\USERNAME\AppData\Local\GitHub\PortableGit_284a859b0e6deba86edc624fef1e4db2aa8241a9\mingw32\etc

there’s no mention of a username or email in it. I can’t find any mention of where the gitconfig file is located if this is not the right one. Do you have the path on your computer or is this the gitconfig file you’re talking about?


#7

And I and who knows how many other people are using Windows who have never had this issue. Like I said, it feels like a config issue.

Do you have the path on your computer or is this the gitconfig file you’re talking about?

In my user folder, right at the top level, there’s a .gitconfig that was created the first time I used git on this machine.


#8

Oh geez I see it now, it’s in:
C:\Users\USERNAME
The correct user name and email are in there.

I found this guy had the same problem but I can’t figure out what he did to fix it.
https ://github.com/hexojs/hexo/issues/1558
(it didn’t wan to let me post a link so I had to add a space after https)

also I’ve never encountered a password prompt, how is it supposed to push to my github without knowing my password? I switched over to ssh like recommended in the package documentation, created the password file key it wants you to create, same password as my github, but it also lets you create a blank password? which is strange it would allow you to do that.


#9
  1. Do you have the environment variables he mentioned?
  2. Have you installed TortoiseGit along with Git for Windows?
  3. The “deploy repo” is probably the remote repo. git@github.com: can be used in place of https://github.com/ in the address and it will go to the same place. I’m not sure that this was actually part of the solution because I don’t know why it would make a difference.

Have you successfully used git from the command line before this?