Can't push to repo using ssh


To start off, I use Windows. I just started using Atom the other day and before I was using vim and git from the command line and pushing to my repo worked fine that way. I’ve tried pushing with both git-plus and git-go packages but it just hangs when I do. git-plus pops up a blank bar at the bottom of the editor and each attempt to push adds another blank bar. git-go just hangs when I type git push.

All that being said, when I saw that Atom had “git integration” I assumed it would natively allow commiting, pushing, etc without additional packages. I still do love using it, but it seems less useful now that I know it doesn’t have “git integration” in the sense I had thought.



Regarding “full blown” Git integration, there’s an official statement on it here:

(It’s linked in the FAQ, but I need to clean up the FAQ a bit to make things easier to find.)



There are several packages to commit etc.



Push works with https if username:password added to url but ssh protocol doesn’t work with atom git-plus