Can't publish theme


#1

I followed all the steps in making a ui theme from atom. I pushed the everything to a repository, and I changed the address in the package.json to the address of the repository. Whenever I try to apm publish minor, I get an error that says “Registering package in kmatherne/oceanline-ui repository failed: That repo does not exist, isn’t an atom package, or you do not have access.” But there is definitely a repository in that name that I have pushed it to.


#2

You forked the repository from atom-dark-ui, which brought the list of tags over from that repository. If you look at the list of tags, you have tags from v0.1.0 through v0.48.0 … but you reset the package version number to v0.0.0, which would increment on apm publish minor to v0.1.0, which is a tag that already exists.

If you put the package version number in your package.json back to the highest tag in the repository OR delete all the tags both locally and remotely, then you should be able to publish just fine.


#3

I tried both methods but it is still giving me the same error.


#4

Have you done apm login?


#5

Thank you! That did the trick.