Can't publish package


Trying to publish my package:

$ apm publish minor
Preparing and tagging a new version ✓
Pushing v0.2.0 tag ✓
Publishing alignment@v0.2.0 ✗
Creating new version failed: Git tag not found

Tags do exist:

$ git tag
$ git ls-remote --tags origin
8dbc4a06c23dd951326f87f152df3b5483b2b2f5    refs/tags/v0.1.0
9bcf0abc79a972ec2b483bb55ec5b91b8b571144    refs/tags/v0.1.0^{}
5c3026aa487637b1ec785a5c3dc4d22749c4d6b5    refs/tags/v0.2.0
3f24477820962ab6d0c7e01b332032132895819e    refs/tags/v0.2.0^{}

Publishing tag explicitly does not work:

$ apm publish --tag v0.2.0
Publishing alignment@v0.2.0 ✗
Creating new version failed: Git tag not found

Unpublish package
Search Can't Find my Theme

It’s happening to me too

$ apm publish --tag v0.4.5
Publishing gistom@v0.4.5 ✗
Creating new version failed: Git tag not found

$ git ls-remote --tags origin
734248cf53f462b6f1961c6ae0f4084593dbf82a refs/tags/v0.4.5
700c2e7fffb15a40f4afa7936a77dcc277c57e15 refs/tags/v0.4.5^{}


had the same problem…

I found that this can happen if you have a lot of unsynced commits local. So now I always push before doing apm publish [version]

ps. the tag has been send to github so you have too remove the tag local and remote, set the old version in package.json and then run apm publish v0.4.5 so you force the right version


I tried but failed.

git add package.json git commit -m ‘version 0.4.4’
[master fa7cf0f] version 0.4.4
1 file changed, 1 insertion(+), 1 deletion(-)
git tag -d v0.4.5 Deleted tag 'v0.4.5' (was 68f7a75) git push origin :v0.4.5

  • [deleted] v0.4.5
    git push Counting objects: 5, done. Delta compression using up to 2 threads. Compressing objects: 100% (3/3), done. Writing objects: 100% (3/3), 286 bytes | 0 bytes/s, done. Total 3 (delta 2), reused 0 (delta 0) To 40bae3d..fa7cf0f master -> master git add .
    git push Everything up-to-date apm publish v0.4.5
    Preparing and tagging a new version ✓
    Pushing v0.4.5 tag ✓
    Publishing gistom@v0.4.5 ✗
    Creating new version failed: Git tag not found


I was encountering this problem. I fixed it by explicitly pushing the tag to git. For instance, if your tag is v0.4.5, you’ll need to execute the command git push origin v0.4.5


I do not know what I did …
but now is working.

I think it worked because I logged again.

$ apm login


Ran in to this problem yesterday.
In my case, it was because I had renamed the repository.
After renaming it back, everything worked fine.


Still running into this problem.
Tried logging in again and tried changing repo name but no luck.
Any ideas?


Me too, I also had something like.

My package was published on Github but not, forced to remove the package and republish with a higher version in order to publish it. Unfortunately, it makes a mess in the versioning and the counters (stars and downloads ) have summers reset to 0.

Announcing: find-selection
Local history of file changes

It looks like it was published as v0.5.0 at one point? But in the repo there are tags for v0.6.0, v0.7.0 and v0.8.0? And it appears that it was forked from another repo?

There are known conflicts when you fork a repo, but reset to an earlier version number than the tags that exist in your new repo. At this point, the only suggestion I can give is to unpublish and republish your package by incrementing from v0.8.0 … probably with an apm publish patch command.


Thanks for the reply.
It was published as v0.5.0 at one point, and now I want to update it.
Ahh. Didn’t realize forking caused issues. I guess I’ll see what I can do, but thanks for the help



I have the same problem right after renaming the repository
I don’t want to get back to the old name because it was causing trouble to those downloading it directly from github (not the right name of the package).

Did anyone find a solution ?

Edit : I added a bug request on apm repo:

Can't publish after changing repository in package.json

I ran into an issue with my upstream being called “github” and apm expected it to be always “origin” A bug report is filed.



I hit this too. The thing that solved it for me in the end was to repush the tag with $ apm publish -t v2.2.2 Note the “v” on the tag, there was quite a while where it wasn’t publishing because I just had “2.2.2”.

Correlated activity:

  • Before the issue, I logged onto this site and had to re-authorize it to access my github profile. Maybe this required atom and gh to have to re-establish atom’s permissions which took longer than the 5 second timeout.
  • Before I got it fixed, I ran an apm login, as suggested in another thread. I suspect that did nothing and I only thought it was continually broken because I had the version wrong by omitting the “v”