Can't publish package. Application error


#1

Can’t publish package. Do anyone has any idea what is happening.

$ apm publish minor
Preparing and tagging a new version ✓
Pushing v0.7.0 tag Username for 'https://github.com' ----
Password for 'https://jchouse@github.com': ----
✓
Publishing atom-css-comb@v0.7.0 ✗
Creating new version failed: Application error

All changes sinking with github. apm pkg is up to date. I havno any ideas.


#2

It might’ve been a temporary atom.io 500 error – have you tried again since then?


#3

Yes, i have that problem more then 1 day


#4

Have you run apm login first?


#5

Yes, you did. But still not working


#6

Is it possible to see the hollow log errors?


#7

Anybody got any idea why this is happening?


#8

It looks like you’re having the same issues as @smlombardi from this topic here:

From that, I’m guessing that your tags are messed up. What’s the name of the repo?


#9

What happened to me was I created the remote repo with tower and it asked for the remote name and git url.

I mistakenly put the name of the repo when I should’ve put “origin” as name.

In this dialog.


#10

Not even close.

Local tags are identical tags in git https://github.com/jchouse/csscomb-atom/releases

It’s not my first release, it’s new version of package: https://atom.io/packages/atom-css-comb
I don’t want to create a new package, I want to continue that which has

I have prepared a release as usual and expected standard of behavior.


#11

A fixed that with hard reset to previous version of package, delete all created tags & force commit to git repo. Then apm publish ... and all done.