Cant open terminal in Atom


#1

Hi,
I’m new to Python. I have installed Atom and the package platformio ide terminal. But whenever I click the + sign, I get this error on windows 10 x64. I also have a windows 7 x64 machine and there it works correctly. Does anyone have an idea what this error means and how I can get it working?
Thanks in advance.


#2

This error has nothing to do with Python. The package is failing to work for reasons related to the Microsoft Visual C++ Runtime Library, as the error states. Specifically, the module pty.js is throwing an error. First, you should reinstall the package. If that doesn’t work, you should try a different package. I don’t have any means of identifying or solving that error, but I found something similar on the pty.js repository.


#3

Thank you very much. I already got through. Just kept clicking on try again for about 10 times. After that everything worked fine. After that whenever I started Atom and got the error, just followed the same procedure. But it didn’t happen anymore. I also updated the package afterwards and still didn’t get the error. Thank you for your reply.


#4

Weird. Glad you got it working.


#5

Thanks buddy, I also had the same problem, checked the entire web for a proper solution, nothing worked and atlast saw your comment. I tried “retry” for around 10 times and it worked.