Can't open preferences pane anymore


#1

Hi,
I started trying atom today, i installed a package called remote-ftp or something like that, suddenly atom doesn’t open preferences pane anymore,it opens a folder called “config” with nothing in it and an empty tab.
I tried safe mode nothing…i tried removing the packages from console…nothing… i tried removing the whole atom, and nothing, debugging say that nothings wrong.
The only way i can see the preferences pane is in dev mode.

Can someone point me into the right direction? what am i missing?

Thanks


#2

If I recall correctly, the only things that Dev Mode does is loads packages from the ~/.atom/dev/packages directory and reloads stylesheets if you’re working on a package. What happens if you:

  1. Close all instances of Atom
  2. Delete the ~/.atom directory
  3. Start Atom again

#3

Ok i tried that, now nothing happens at all nor tab nor nothing :S


#4

This is what i get nothing else when i hit configure hope there’s a solution, i really loved the little time i had to play with it haha.


#5

What do you mean by “when I hit configure”? How are you trying to open the Preferences?


#6

Sorry i meant “when i hit Atom > preferences”, if i don’t have a project a tab with that folder opens and nothing else if i do have a project opened then nothing opens, its weird since its a clean installation.


#7

So here’s an image of what’s in my title bar on my currently open project:

I find it curious that the path in yours says atom:/config. I don’t know how that path could have gotten there, since it isn’t a real path. How are you launching Atom when you do?


#8

Atom uses atom.workspace.open('atom://config') to open the settings view, so that’s where that’s coming from. Maybe there’s a problem with the custom protocol on your machine.

edit Oh wait, I see now that there’s only one / in your title bar, maybe that’s where things go wrong, because it should be two /s I think.


#9

So this is what i get if i use “open your config”, theres the path that Olmokramer says.


#10

and this is the path if i hit the “preferences” option

so as Olmokramer says there’s only one “/”, does anyone knows how can i fix the path?

Thanks for all the help!


#11

Are you certain you deleted the ~/.atom directory in my instructions above? Something seems to have gotten corrupted.


#12

This is what i did
1- close every atom
2- use this on the terminal rm -rf ~/.atom
3 - started again
4 - window of welcome appears
5 - Selected “choose a theme” > open theme picker
6 - preferences panel appears like normal with “atom://config” in the title bar
7 - close preferences and every tab
8 - open Atom > preferences
9 - an empty tab appears and in the title bar appears “atom:/config” and nothing else


#13

FINALLYYYYY i discovered what happened :grin:

1 - went to the terminal and inserted this defaults write com.apple.finder AppleShowAllFiles YES , to see hidden files on my mac.
2 - Somehow i had a folder in my root called “atom/” that i didn’t saw before it contained a folder called “config” with nothing in it.
3 - Deleted that folder empty trash.
4 - Finally i can open preferences panel again!!!


#14

Wow, a folder with a / in its name? :scream: Didn’t know that was possible!


#15

i installed an ftp package after that i couldn’t open preference pane anymore, not sure if it was the package or not :confused:


#16

Actually *nix supports any character in a name, including invisible control characters. I’ve had files that were hell to delete.


Files with slashes on Linux and Mac?
#17

5 posts were split to a new topic: Files with slashes on Linux and Mac?


Files with slashes on Linux and Mac?
#18

thank you very much its working


Files with slashes on Linux and Mac?
#19

I had the same problem. I didn’t find an atom/ folder, but I followed the advice of deleting ~/.atom. This, of course, removed all my installed packages. I’m pretty new to Atom and wasn’t expecting this, and I’ve gotta say I’m not particularly happy starting over was the solution. I’d customized a number of packages and now they’re just… gone. So now I’m hunting down my packages and reconfiguring them.

All that to say, I hope others post here when they experience the problem and that eventually a proper solution is found.


Files with slashes on Linux and Mac?
#20

Unless you’ve cleared your system trash, the packages are probably there. For future reference, renaming a config folder is as good as deleting it, because Atom can’t know when you’ve renamed the folder and just sees it as not being there.

Removing the config folder and forcing Atom to create a fresh one is the proper next step when you don’t know why an error is occurring but you need to verify that it’s something in your local setup. Occasionally, it’s necessary to scrub an old config folder and copy packages/ and the config files into a new one.