Can't launch apm or atom from command line: /atom/bin/ scripts point to old version


#1

Hi all,

I tried running apm from the command line and was presented with this error:
~/AppData/Local/atom/bin/apm: line 2: ~/AppData/Local/atom/bin/../app-1.18.0/resources/cli/apm.sh: No such file or directory

It turns out I can’t run any apm command, nor can I run atom from the command line. Running atom via a shortcut pointing to ~/AppData/Local/atom/atom.exe seems to open atom without any issue.

I looked at the contents of ~/AppData/Local/atom and see the following:

.
|-- SquirrelSetup.log
|-- Update.exe
|-- app-1.17.2
|   `-- resources
|-- app-1.19.0
|   |--  ...more files ...
|   `-- 
|-- app-1.19.1
|   |--  ...more files ...
|   `-- 
|-- app.ico
|-- atom.exe
|-- atom_scb.bat
|-- bin
|   |-- apm
|   |-- apm.cmd
|   |-- atom
|   `-- atom.cmd
`-- packages
    |-- RELEASES
    |-- SquirrelTemp
    |-- atom-1.19.1-delta.nupkg
    `-- atom-1.19.1-full.nupkg
11 directories, 48 files

If I look inthe contents of any of the bin/ scripts (apm, apm.cmd, atom, atom.cmd) they’re all pointing to app version 1.18.0. For example, the contents of bin/apm is as follows:

#!/bin/sh
"$(dirname "$0")/../app-1.18.0/resources/cli/apm.sh" "$@"

Notice that in the directory tree above, there are only app folders for 1.17.2, 1.19.0 and 1.19.1. No 1.18.0. If I change the path in those scripts to 1.19.1 for example, I get a different error so I changed them back to the 1.18 versions. I’ve tried updating atom from insdie atom and from Update.exe but it seems the /bin/ scripts are still pointing at the 1.18.0 version. I don’t know when atom was updated but I suspect I haven’t tried running apm or atom from command line since.

Has anyone else had this problem or have any ideas what to do to fix the paths? Not thrilled about the idea of uninstalling and reinstalling.

Versions

  • Atom: 1.19.1
  • Atom-Shell:
  • OS: Microsoft Windows 10 Enterprise
  • Misc
    • apm 1.18.4
    • npm 3.10.10
    • node 6.9.5 ia32
    • python 3.5.2
    • git 2.10.1.windows.1
    • visual studio