Can't install some packages


#1

I got Atom more than a year ago and have been using it fine, but wasn’t ever able to install atom-beautify, then, after some time, I tried to update linter-js-standard, and couldn’t do it anymore as well, tried removing linter-js and reinstalling and it doesn’t install anymore, then tried wiping everything atom on my computer and doing it from scratch, and can’t install both of them anymore, but was fine to install other packages.

Anyone could shed a light on this?

Thanks in advance.

Installing atom-beautify to C:\Users\adiab\.atom\packages failed

> atom-beautify@0.29.10 postinstall C:\Users\adiab\AppData\Local\Temp\apm-install-dir-116627-5640-10au3yj\node_modules\atom-beautify
> node script/build-options.js


npm WARN engine typescript-formatter@2.3.0: wanted: {"node":">= 4.2.0"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN deprecated minimatch@0.2.12: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN engine glob-expand@0.2.0: wanted: {"node":">0.10 <=5"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm ERR! registry error parsing json
npm ERR! registry error parsing json
npm ERR! registry error parsing json
npm ERR! registry error parsing json
npm ERR! registry error parsing json
npm ERR! registry error parsing json
npm ERR! registry error parsing json
npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN optional dep failed, continuing fsevents@1.0.14
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})

module.js:340
    throw err;
          ^
Error: Cannot find module 'd:\script\build-options.js'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:935:3
npm ERR! Windows_NT 6.2.9200
npm ERR! argv "C:\\Users\\adiab\\AppData\\Local\\atom\\app-1.8.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\adiab\\AppData\\Local\\atom\\app-1.8.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\adiab\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\adiab\\.atom\\.apmrc" "install" "C:\\Users\\adiab\\AppData\\Local\\Temp\\d-116627-5640-j7bqq6\\package.tgz" "--target=0.36.8" "--arch=ia32"
npm ERR! node v0.10.40
npm ERR! npm  v2.13.3
npm ERR! code ELIFECYCLE

npm ERR! atom-beautify@0.29.10 postinstall: `node script/build-options.js`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the atom-beautify@0.29.10 postinstall script 'node script/build-options.js'.
npm ERR! This is most likely a problem with the atom-beautify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node script/build-options.js
npm ERR! You can get their info via:
npm ERR!     npm owner ls atom-beautify
npm ERR! There is likely additional logging output above.





c:\Users\adiab\.atom>apm install linter-js-standard
Installing linter-js-standard to C:\Users\adiab\.atom\packages failed

> spawn-sync@1.0.15 postinstall C:\Users\adiab\AppData\Local\Temp\apm-install-dir-116627-15744-1k0yl19\node_modules\linter-js-standard\node_modules\happiness\node_modules\happiness-format\node_modules\esformatter\node_modules\npm-run\node_modules\spawn-sync
> node postinstall


> spawn-sync@1.0.15 postinstall C:\Users\adiab\AppData\Local\Temp\apm-install-dir-116627-15744-1k0yl19\node_modules\linter-js-standard\node_modules\semistandard\node_modules\semistandard-format\node_modules\standard-format\node_modules\esformatter\node_modules\npm-run\node_modules\spawn-sync
> node postinstall


> spawn-sync@1.0.15 postinstall C:\Users\adiab\AppData\Local\Temp\apm-install-dir-116627-15744-1k0yl19\node_modules\linter-js-standard\node_modules\standard\node_modules\standard-format\node_modules\esformatter\node_modules\npm-run\node_modules\spawn-sync
> node postinstall


npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN engine deep-extend@0.4.1: wanted: {"node":">=0.12.0","iojs":">=1.0.0"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine get-stdin@5.0.1: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine get-stdin@5.0.1: wanted: {"node":">=0.12.0"} (current: {"node":"0.10.40","npm":"2.13.3"})

module.js:340
    throw err;
          ^
Error: Cannot find module 'd:\postinstall'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:935:3

module.js:340
    throw err;
          ^
Error: Cannot find module 'd:\postinstall'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:935:3
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm WARN engine is-buffer@1.1.3: wanted: {"node":">=0.12"} (current: {"node":"0.10.40","npm":"2.13.3"})
npm ERR! Windows_NT 6.2.9200
npm ERR! argv "C:\\Users\\adiab\\AppData\\Local\\atom\\app-1.8.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\adiab\\AppData\\Local\\atom\\app-1.8.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\adiab\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\adiab\\.atom\\.apmrc" "install" "C:\\Users\\adiab\\AppData\\Local\\Temp\\d-116627-15744-lrkcf\\package.tgz" "--target=0.36.8" "--arch=ia32"
npm ERR! node v0.10.40
npm ERR! npm  v2.13.3
npm ERR! code ELIFECYCLE

npm ERR! spawn-sync@1.0.15 postinstall: `node postinstall`
npm ERR! Exit status 8
npm ERR!
npm ERR! Failed at the spawn-sync@1.0.15 postinstall script 'node postinstall'.
npm ERR! This is most likely a problem with the spawn-sync package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node postinstall
npm ERR! You can get their info via:
npm ERR!     npm owner ls spawn-sync
npm ERR! There is likely additional logging output above.

#2

What command are you using to install the packages?


#3

Tried apm install atom-beautify/linter-js-standard as well trying from inside atom. Same error.
Edit: Installed linter from inside atom and it worked, then tried installing minimap from command line, also worked, clicking on packages on atom afterwards showed minimap installed.


#4

I’m not sure why it thinks some scripts are on your D: drive. But it looks like both of these packages include a “postinstall” script in their package.json and that is what is failing on your system. You should probably file a bug on their Issues lists. The Atom FAQ has information on how to contact the maintainers of any Atom community package or theme.


#5

Alright, will try that.
Thank you again.