Cant install Script Package in atom! Help!


#1

Error Code:

Installing “script@3.17.3” failed.Hide output…
C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9
`-- (empty)

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules\script\node_modules\chokidar\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\package.json’
npm WARN apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9 No description
npm WARN apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9 No repository field.
npm WARN apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9 No README data
npm WARN apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9 No license field.
npm ERR! Windows_NT 10.0.17120
npm ERR! argv “C:\ProgramData\vargh\atom\app-1.25.0\resources\app\apm\bin\node.exe” “C:\ProgramData\vargh\atom\app-1.25.0\resources\app\apm\node_modules\npm\bin\npm-cli.js” “–globalconfig” “C:\Users\vargh\.atom\.apm\.apmrc” “–userconfig” “C:\Users\vargh\.atom\.apmrc” “install” “C:\Users\vargh\AppData\Local\Temp\d-118219-3692-1ez37h4.3wdas5g66r\package.tgz” “–runtime=electron” “–target=1.7.11” “–arch=x64” “–global-style”
npm ERR! node v6.9.5
npm ERR! npm v3.10.10
npm ERR! path C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules.staging\ansi-regex-19858eec
npm ERR! code EPERM
npm ERR! errno -4048
npm ERR! syscall rename

npm ERR! Error: EPERM: operation not permitted, rename ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules.staging\ansi-regex-19858eec’ -> ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules\script\node_modules\ansi-regex’
npm ERR! at destStatted (C:\ProgramData\vargh\atom\app-1.25.0\resources\app\apm\node_modules\npm\lib\install\action\finalize.js:25:7)
npm ERR! at C:\ProgramData\vargh\atom\app-1.25.0\resources\app\apm\node_modules\npm\node_modules\graceful-fs\polyfills.js:264:29
npm ERR! at FSReqWrap.oncomplete (fs.js:123:15)
npm ERR!
npm ERR! Error: EPERM: operation not permitted, rename ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules.staging\ansi-regex-19858eec’ -> ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules\script\node_modules\ansi-regex’
npm ERR! at Error (native)
npm ERR! { Error: EPERM: operation not permitted, rename ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules.staging\ansi-regex-19858eec’ -> ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules\script\node_modules\ansi-regex’
npm ERR! at destStatted (C:\ProgramData\vargh\atom\app-1.25.0\resources\app\apm\node_modules\npm\lib\install\action\finalize.js:25:7)
npm ERR! at C:\ProgramData\vargh\atom\app-1.25.0\resources\app\apm\node_modules\npm\node_modules\graceful-fs\polyfills.js:264:29
npm ERR! at FSReqWrap.oncomplete (fs.js:123:15)
npm ERR!
npm ERR! Error: EPERM: operation not permitted, rename ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules.staging\ansi-regex-19858eec’ -> ‘C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\node_modules\script\node_modules\ansi-regex’
npm ERR! at Error (native) parent: ‘script’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\vargh\AppData\Local\Temp\apm-install-dir-118219-3692-12jwsaa.mpd8daq0k9\npm-debug.log
npm ERR! code 1

Idk whats wrong, hope you guys can help!


#2

Looks like your OS isn’t supported. Which are you using?

Edit: Windows it looks like. Which version?


#4

WIndows 10, 64 Bit


#5
DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

I think this is the error.


#6

hmmm so it doesnt support 64bit?


#7

Was this trying to install the script package?


#8

yea, the script package from the atom editor


#9

i tried hydrogen script too, same error


#10

Hmm. It definitely works on Windows. I can’t help much though, besides recommending you try again or something.


#11

hmm, idk whats wrong then, it seems other people also have this issue.