Can't install packages


#1

I am trying to install a package (Hydrogen) but I can’t, because I get this error:

> zmq@2.15.3 install C:\Users\JORDAN~1\AppData\Local\Temp\apm-install-dir-11672-8972-1vrxp0c\node_modules\deuterium\node_modules\jmp\node_modules\zmq
> node-gyp rebuild


C:\Users\JORDAN~1\AppData\Local\Temp\apm-install-dir-11672-8972-1vrxp0c\node_modules\deuterium\node_modules\jmp\node_modules\zmq>if not defined npm_config_node_gyp (node "C:\Users\Jordan Baron\AppData\Local\atom\app-1.9.0\resources\app\apm\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node  rebuild ) 

npm ERR! Windows_NT 6.2.9200
npm ERR! argv "C:\\Users\\Jordan Baron\\AppData\\Local\\atom\\app-1.9.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\Jordan Baron\\AppData\\Local\\atom\\app-1.9.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig"     "C:\\Users\\Jordan Baron\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\Jordan Baron\\.atom\\.apmrc" "install" "C:\\Users\\JORDAN~1\\AppData\\Local\\Temp\\d-11672-8972-    ovgc8u\\package.tgz" "--target=0.37.8" "--arch=ia32"
npm ERR! node v0.10.40
npm ERR! npm  v2.13.3
npm ERR! code ELIFECYCLE

npm ERR! zmq@2.15.3 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the zmq@2.15.3 install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the zmq package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls zmq
npm ERR! There is likely additional logging output above.

It does this when I try to install other packages, it gives me the same error. The only packages I have installed are the default ones that come with Atom. I am on Windows 10 64-bit.


#2

Hi @jordanbaron, can you try installing the Atom Beta and see if that helps? The beta version has a lot of improvements concerning package installation.


#3

I tried it, but it still doesn’t work :expressionless:


#4

What version of VisualStudio do you have installed and do you have a GYP_MSVS_VERSION environment variable set?


#5

I have the latest version of Visual Studio and I am unsure what GYP_MSVS_VERSION is


#6

It’s an environment variable that the node-gyp package relies on. If you don’t have it set, you need to (if you have VS 2015, set it to 2015).


#7

I did that and it doesn’t work. I’ve basically tried everything.


#8

So you’re giving up? Because you’ve stopped offering information, and nobody here can help you figure out what’s wrong without information.