Can't install packages with 1.25


#1

I got error “unable to get local issuer certificate” when I tried to search for a package to install. I am not behind a firewall or using proxy. Even after I add “strict-ssl=false” in both .atom/.apm/.apmrc and .atom/.apmrc, I still got the same error


#2

Were you able to install packages before? Are you able to install packages if you download and run 1.24? Test with the zip file appropriate for your OS, not AtomSetup.exe. That way, you can have two versions of Atom in different places on your computer and you can do comparison testing.


#3

1.24.1 works with the installs. I guess I will switch to the older version for now.


#4

Sounds good. You should also make an issue post on the APM repo, and maybe someone will see one of the two threads who knows why that would have happened.


#5

As it turns out, after I successfully installed a bunch of packages and themes with 1.24, it stopped working all of a sudden. I could not install packages any more due to the same error before. Don’t know what caused it. I uninstalled some of the most recent packages installed and it did not help. It is really weird