Can't install packages from inside Atom


#1

Hi,

cant seem to install packages from inside Atom. Using Atom, file, settings, packages. Then search for csharp for example.

Following Error occurs.

Searching for “csharp” failed.Hide output…
getaddrinfo ENOTFOUND


Can apm download pacakage through socks5 or http proxy?
#2

Sounds like a connection issue. Are you behind a firewall or proxy of some sort?


#3

You specifically state that you can’t install them from inside Atom. Does this mean that apm from the command-line works?


#4

Havent tried APM yet. Im also behind a proxy. But havent run into any problems with that earlier. Installed Atom using chocolatey using the same proxy.

tried APM. Same error as inside the UI.


#5

There are instructions on how to handle a proxy at the bottom of the apm README:


#6

I have been facing the same problem ever since. It runs after 10-15 tries.


#7

Yea this piece never worked for me, say if trying to install packages from within Starbucks’ wifi:
strict-ssl = false

Not knowing the proxy, I thought the above would be enough to get around SSL restrictions, but didn’t.
Does this only work on Mac or somethin’?


#8

I don’t know, I don’t have a situation where I’ve ever needed to use the proxy support. I also only have Macs :grinning:


#9

I’ve got the same problem. apm on the commandline works fine.


#10

I can confirm what @mz2 has stated. I have configured apm to use a proxy in the .apmrc file and apm works. However in the Available Updates and Install panels of settings I get this error: getaddrinfo ENOTFOUND. I am also using a Mac behind a firewall.

I’ve tested using the Atom icon and launching atom from the command line, same results in both cases.


#11

Please report this on the atom/settings-view repo if it hasn’t been already. Please include the following information:

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#12

OK, I worked around the problem. My environment variables use http_proxy notation but Atom expects http-proxy. When I set the http*-proxy vars Atom works.


#13

I also have this problem. I am using the latest version of Atom: 0.209.0

I am on OSX. 10.10

No packages come up in the search inside the preferences inside Atom but apm installs them fine.

Using atom --safe does not work.

I am behind a transparent proxy.

My current work around is to just use apm in the console.


#14

It’s been a while since I last tried Atom. It’s polishing up nicely. Running (occasionally) in to a similar issue here. For me, its a ‘search’ issue. Sometimes I can search in the UI. Sometimes I can’t.

Reproducer:
Mac OSX 10.10.3
Atom 1.0.0

  1. Quit all instances of Atom
  2. Start Atom
  3. CMD, to get to Preferences (aka Settings)
  4. Click ‘Install Packages’ pane
  5. Search for something (in my case, I search for ‘scss’) and hit the return key (should conduct the search)
  6. Close the Settings tab
  7. CMD, to get to Preferences (aka Settings) once again
  8. Type something new in the Install Package search box and hit enter… notice that searching is no longer working

FYI… searching/installing via apm works for me so it’s not a network issue.


#15

@whitej125 Atom.io and the package repo has been having sporadic issues all day due to being overloaded after the 1.0 announcements.

Unless it’s been the same for you yesterday, give it a little while?


#16

There is already a bug open for that, the current workaround is to click the Themes button and then back to the Packages button, it’ll start searching.

You can be kept up to date on the status of this by subscribing here: