Can't install atom packages


#1

hi there !
so i want to install term2 for atom.
but i have a error

pty.js@0.2.13 install C:\Users\Jeroen\AppData\Local\Temp\apm-install-dir-115721-5672-wkj2b3\node_modules\term2\node_modules\pty.js
node-gyp rebuild

C:\Users\Jeroen\AppData\Local\Temp\apm-install-dir-115721-5672-wkj2b3\node_modules\term2\node_modules\pty.js>node “C:\Users\Jeroen\AppData\Local\atom\app-1.0.7\resources\app\apm\node_modules\npm\bin\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild

gypnpm ERR! Windows_NT 6.2.9200
npm ERR! argv “C:\Users\Jeroen\AppData\Local\atom\app-1.0.7\resources\app\apm\bin\\node.exe” “C:\Users\Jeroen\AppData\Local\atom\app-1.0.7\resources\app\apm\node_modules\npm\bin\npm-cli.js” “–globalconfig” “C:\Users\Jeroen\.atom\.apm\.apmrc” “–userconfig” “C:\Users\Jeroen\.atom\.apmrc” “install” “C:\Users\Jeroen\AppData\Local\Temp\d-115721-5672-1gjxrvl\package.tgz” “–target=0.22.0” "–arch=ia32"
npm ERR! node v0.10.35
npm ERR! npm v2.5.1
npm ERR! code ELIFECYCLE

npm ERR! pty.js@0.2.13 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the pty.js@0.2.13 install script ‘node-gyp rebuild’.
npm ERR! This is most likely a problem with the pty.js package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls pty.js
npm ERR! There is likely additional logging output above.

Please help me !


#2

Such node-gyp errors are usually caused by Windows build tools not being installed, or not the right ones anyway.
I’m never sure exactly which VC++ libraries are needed, but they’re usually covered by installing Visual Studio 2010 or 2013.

Presumably, this doesn’t happen with every package, have you tried a few others?


#3

The similar problem with me.

error log of term3 installation: https://gist.github.com/wonderbeyond/7fbef5abc5aa390569ec#file-error-log-atom-install-term3

error log of term2 installation: https://gist.github.com/wonderbeyond/7fbef5abc5aa390569ec#file-error-log-atom-install-term2