Can't install any version of atom on Ubuntu 16.04


#1

I’ve been running Atom in Ubuntu 16.04 for a while, but I started having crippling issues a few weeks ago. Atom just stopped working one day. I opened it, and the program came up, but as soon as I tried to open a file, save, do anything, the Atom froze and crashed. Since then, I haven’t been able to get it to work. I’ve tried multiple versions, 1.19.2 (both through Ubuntu Software and downloading the package), and a few other versions.

For a while, I was getting an error message:

But now I get almost nothing. I can click the “Install” button, but besied the button looking like it was clicked but then doing nothing. I can click the button over and over and nothing happens.

I’m dual-booting Windows 10 and Ubuntu 16.04 on an ASUS UX31A with a Crucial 512GB SSD, 1.9GHz i7 with Intel HD4000 Graphics, 4GB RAM.


#2

EDIT: If I try to install through Ubuntu Software, I get the error message pictured above. If I download the installer from atom.io and run it manually, I get nothing except a not so fun little button to push.


#3

The Ubuntu Software error sounds like a problem with the package manager, especially since it returns a 400 error. I can’t offer any insight on why the package isn’t working unless you see an error message (you might get more output if you try installing it on the command line). GUIs tend to obfuscate error messages, and that’s not so bad on Linux, but operating through the command line will always provide more information.

You can always try building Atom from source. You’re on a recent version of Ubuntu, so it should be a seamless process if you follow the instructions.


#5

Built from source and it’s working so far. Thanks for the help