Can't install any package in atom


#1

It displays only this error:
I cant install any package in my atom editor. It displays following error message:
"Fetching featured packages failed.Hide output… write EPROTO 101057795:error:140943F2:SSL routines:ssl3_read_bytes:sslv3 alert unexpected message:openssl\ssl\s3_pkt.c:1493:SSL alert number 10 101057795:error:1409E0E5:SSL routines:ssl3_write_bytes:ssl handshake failure:openssl\ssl\s3_pkt.c:659:


#2

The SSL handshake error indicates that some entity along the chain isn’t secure enough for the package manager. It’s probably associated with the network you’re using to connect to the Internet.


#3

I am using my mobile network. what should I do?


#4

Do you have access to wifi?


#5

Yes, I have. I tried from my both of network. But the problem is still same.


#6

Related: EPROTO 101057795:error:140943F2 Installing Packages under Windows 10 Home on UP Squared ?


#7

I would like to confirm this issue. Seems to be related to the link you provided.
And I also found some other stuff where it probably relates to. [1] So I assume that this SSL warning is not network releated but related to some issue in Node.js upon which electron is built. Hopefully it’s not that hard to fix then for any dev. So, this seems to be the underlying error:
[1] https://github.com/nodejs/node/issues/12691

So, probably gonna submit this as issue to the github tracker. (a short query there didn’t show me anything related.)


#8

Install a 32-bit version of atom.