Can't get PHP comments to work


#1

Hi… How did the problem get fixed?

I’ve just installed atom and cant get php comments to work. Googled a lot for answers and everywhere they speak of html or js comments.

Any additional package you needed to install?
cmd + / gives me normal html comments only.


Comments command in PHP broken
#2

Atom has made so much progress in the past year, that I’m pretty certain the solution that fixed it then isn’t applicable to your situation. Can you give us a little more information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?
  • Can you describe exactly what the issue is?

#3

I’m using the latest version.
Atom Version: 1.0.0
Mac OS X

I tried with atom --safe and it works perfectly. Thanks a million for that tip.

But without the --safe option only html comments appear.
Tried commenting on php, css, js, coffee… in all places only html comments come up.

In safe mode all the above comments work well.

For now i can work with the --safe option but am wondering if it works in safe why not in the normal mode.


#4

Do you have the Emmett package installed? If so that may well be the culprit …


#5

Yeah. uninstalled emmett. works perfectly now.
Thanks :smile:


#6

The Emmett package cause me lots of problems. I’m constantly disabling it and reenabling depending on what I’m doing. I find Emmett far too useful to do without completely, but it’s also kind of a PITA.


#7

Does the package have issues posted for these problems?


#8

Oh yes, multiple times. The Emmett package has over a hundred open issues. Many of them regarding how it interacts poorly either with Atom’s default behaviours or with other packages.