Can't edit files when I open up a project folder


#1

I just updated Atom to 1.17 and started getting a problem where I cannot edit files when I open up a project. The status bar goes blank and the editor cursor completely disappears. It doesn’t even show up on the Settings tab text input boxes. The only way to circumvent the issue is to open up files in a window that does not have the project browser. Then everything functions as normal.

Is anyone else having this issue?


#2

Yep. Having the same issue. As soon as I add a project folder, I can’t edit anything.


#3

This fixed it for me:

Go to the Tree View package (I have ver. 0.217.0-7) and turn off “Focus on Reveal”.


#4

Hmm, did turning off that setting work for your too @sharkweek?

There was also this recent issue where a couple of folks had a similar problem and had to disable the synced-sidebar package:

Did either of you happen to have that package installed?


#5

That did the trick! Thanks @MattWalker!

@rsese, no, I don’t have that package installed.


#6

Thanks for confirming @sharkweek :v: Also thanks for dropping a note in the issue too.


#7

I can confirm that turning off “Focus on Reveal” fixed it for me.

For clarification of the issue:

  • All keystrokes were going to the Tree View.
    • If I clicked on the edit pane and pressed"up-arrow", the cursor moved up in the Tree VIew.
    • If I clicked on the edit pane and pressed"d", it would start the process to duplicate the file selected in the Tree View.
  • Note: I needed to use the mouse to find and change the “Focus on Reveal” setting since the keyboard was not working in the settings dialogs either.