Can't download atom from anywhere


#1

I have tried downloading from the following places:

https://github.com/atom/atom/releases/download/v0.154.0/AtomSetup.exe
https://github.com/atom/atom/releases/download/v0.154.0/atom-windows.zip
"https://atom.io/download/windows"

Each time it starts normally and then it just cuts out.
If I download in Chrome it fails after about 5 minutes.
If I download with FreeDownloadManager, then the time it takes to cut out varies, but in the log it either says “Response is invalid.” Or it just drops the connection. Or it says “Incorrect username or password”

I also tried downloading/installing via Chocolatey. This was what I got:
"The operation has timed out

Command ‘install’ failed (sometimes this indicates a partial failure). Additional info/packages: atom"

This is not a network/ISP/firewall issue. I can browse any site on the internet (including all the atom.io sites and Github) I can download anything I want (besides atom) And I have no problem installing any packages with Chocolatey (besides atom)

Edit: I found the issue. It was a very weird firewall rule. Sorry.


#2

I’ve tried downloading it from the same locations you mention, for me it works on all of them without any trouble.

Your comment of “Don’t you want people to use Atom” doesn’t make much sense to me, the very fact that there are such a multitude of ways to download/install it means that they DO want people to use Atom, those ways just happen to not be working for you personally.


#3

Are you behind any kind of internet filtering?

Do you have any antivirus on your computer that might be rejecting the download?


#4

Well there is a firewall, but it is allowing all traffic through. And I can download anything I want except atom…

And I tried with all antimalware software not running.


#5

I was just able to download from all three locations that you linked without issue. Are you able to download releases from other GitHub projects? You may want to contact GitHub Support directly. They may have more information on troubleshooting steps than we do.