Can't delete a file created with Atom (Windows 10)


#1

In Atom, I created a new folder, and then created a file within the folder, but weirdly found that I couldn’t open the file I had just created. I closed Atom and reopened, tried again, still no luck. Since it was a brand new empty file I figured I would just delete it and recreate it, but then I found that I wasn’t able to do that either.

Windows asked for Admin permissions to delete the file, which I gave, but nothing happened. After some Googling I opened the File Properties, went to the Security tab, and found that the file had no owner and no users had any permissions for it. So assigned the file’s ownership to my own account, and gave myself full control permissions, as well as granting permissions to the Administrators user group and to SYSTEM, and tried deleting the file again. Now it doesn’t ask for admin permissions and the file immediately disappears from the folder. But if I hit F5, or back out of the folder and go back in, it’s still there.

If I try to send the file to the Recycle Bin instead of permanently deleting it with Shift+Del, I get this error message: “The file ‘Aux.js’ is too large for the destination file system.” The size is listed as 0 bytes. If I try to rename the file, I get the same error. If I try to move the file to a different folder, I get a different error message: “An unexpected error is keeping you from moving the file. Error 0x800704B0: The specified device name is invalid.”

I searched the error code without much luck. I’ve tried running System File Checker, DISM, and ChkDsk — but the latter sat on 10% for more than an hour so I canceled it because I am not going to stare at a progress bar for hours just to delete one file. I am on the verge of losing my mind though. How do I delete this thing, and more importantly, how did this happen in the first place? I don’t want to have to go through the same headache next time I need to create a new directory or file in Atom.


#2

I was finally able to delete the file by booting into Ubuntu on a bootable USB drive and deleting it from there. However, when I opened Atom again and attempted to recreate the file, the exact same problem happened again. I then tried creating the file in a different directory — same problem. Finally I tried creating a new directory and file with different file names — that worked. I then tried creating the file with the same name as before in a different project, on a completely different drive, and again it’s unopenable, undeletable. What the hell is going on here? The filename is ‘Aux.js’.


#3

Could it be this?

https://bitquabit.com/post/zombie-operating-systems-and-aspnet-mvc/

Does the file name cause issues with other editors?


#4

Yep, that’s the issue. I Googled it after narrowing down the problem to the filename. Bug report posted here: https://github.com/atom/atom/issues/17175