Cannot use git bash/cmd while atom file is open


#1

Following the learnhowtoprogram.com guide for git bash / atom:

Installed the newest versions of git bash and atom literally today, and whenever I open a file with atom through gitbash it will open the file, but I can’t use gitbash (it is stuck processing the atom file command) until I close the atom file.

image

Once I close atom, this message reads in git bash (also in the windows terminal when I tried it there) and then I can use gitbash again:

$ atom wtf.md

Attempting to call a function in a renderer window that has been closed or released.
Function provided here: Object. (C:\Users\lex\AppData\Local\atom\app-1.34.0\resources\app.asar\node_modules\github\lib\worker.js:61:22
Remote event names: destroyed, crashed

Please note that my system variables environment path was set to my atom folder before trying to open any files:

C:\Users\lex\AppData\Local\atom\app-1.34.0

There is no text in the md file, just created it for troubleshooting but I also tried to open other files I have been working on with gitbash/atom and the same issue occurs.

I went through the atom support checklist, and tried all of the troubleshooting tips and it still isn’t working.

Windows 10 x64
Atom 1.34.0 x64

Please help, and let me know if you need any additional information.


#2

The video you posted has nothing about git bash or Atom. It’s hard to reference the source material when the link you post doesn’t have relevance to the situation at hand.

I believe what you’re seeing as a bug is just normal bash behavior (bash, of course, always behaves as if your computer is running Linux; that’s the point of using it). In Linux, when you start an application from the terminal, the terminal waits for output from the application or for it to exit, unless you explicitly background the application’s process and release the terminal to do other things. You’re using Windows, so Atom doesn’t have a switch to tell it to hide in the background since that’s not usually a consideration for Windows programs. The solution is to not open Atom from inside git bash, or if you have to, open another window of git bash and do all of your CLI stuff in there. You don’t need to use git bash in order to use git; the normal command line works the same way and if you install cmder it works better.


#3

What’s your opinion on PowerShell? I’ve finally moved to dual booting Windows + Linux, and PowerShell feels very familiar and “command friendly”.


#4

I almost never use it, have never had a project that required it, and don’t see a reason to become expert in different shells on Windows.