Cannot update packages


#1

Hi, I can see the package list in the Install menu, I can install them, but I cannot get the list for the packages that are outdated (Updates) thus I cannot update any package. Updating atom works fine btw. Now I did check https://github.com/atom/apm#behind-a-firewall and I ran apm config set strict-ssl false, but nothing changed. I also checked if I am behind a firewall or a proxy server (via various websites) but I do not have any firewall nor do any proxy checkers tell me that I am behind a proxy. This is the exact error message:

Fetching outdated packages and themes failed.Show output…

Request for package information failed: connect ETIMEDOUT {ip:port}

I have no idea how to fix this, please help thank you!


#2

What happens when you try to run apm upgrade?


#3

C:\Users\felyx>apm upgrade
Request for package information failed: connect ETIMEDOUT {ip:port}


#4

Sometimes one or two package shows up when I click on the Update tab I am even able to update them but most of the times it still says:

Fetching outdated packages and themes failed.Show output…
Request for package information failed: connect ETIMEDOUT

Please if anyone knows the solution let me know.


#5

@leedohm might be better able to help.


#6

ETIMEDOUT means that the network connection timed out for one reason or another. We’ve seen sporadic reports of this but haven’t been able to reproduce the problem. Do any of the linked issues apply to your situation?


#7

Yes, it seems im in those few ppl who arent behind a proxy nor do I use firewall but still cant get the list of the packages which needs to be updated for some reason.


#8

I asked my ISP, they do not limit my connection in any way, no proxy, no firewall, so I have no idea whats up, maybe my router blocks it but then again everything else works fine besides Atom.


#9

Well I found the cause for this problem, without router (straight connection) everything works, when I use my router it does not.