Cannot type the "\" inside an editor window. (Windows)


#1

Keyboard generally works. Even in the settings page I CAN type the “” . It just is ignored in editor windows of any sort (tried json, cons, coffee).

How can I debug this?
Any hints or ideas?


#2

Try opening the key binding resolver with Ctrl+., then hit the \ key. Does it resolve to a command?

PS: make sure the editor is focused when you hit the \


#3

What @olmokramer said.
If the key binding resolver doesn’t show you any output when you try the backslash, there may be a package that interferes with keyboard input, but try the resolver first.

Also, for completeness, what keyboard layout are you using? OS, Atom version etc.


#4

OS = Windows (see title)
Atom = 0.169.0
Keyboard = german, generally key mapping is correct

Itried they way olmokramer recommended already, the problem is: the field “search keybindings” searches by the name of the command and NOT by the keyboard-shortcut. So when I type “” then I can see the"" in the search-field and nothing else happens, because there is no command with name “”.

I also assume that there is a keybinding in effect. However this is a total fresh install and everybody on Windows with a german keyboard should have this issue. (Ok, I have an apple keyboard attached with some keymappings required, but the \ key is not remapped)

In case you want me to debug something with dev–tools will do.

thx for the quick replies.


#5

So this will be the issue with international keyboards and your Alt-Gr characters (see this issue on the keymap repo, which is still open). That Alt-Gr key is not well-supported.

I’d say follow that issue to see when it gets fixed.


#6

Ok, when I type “ctrl-alt” in the searchfield then I see a list of mappings (about 40) . Cannot find one that would map to the “?ß” key, which is the \ key.

Will follow this. Thx


#7

I’m not sure we’re talking about the same key binding resolver. So just to be sure, I wasn’t talking about the search-field in the keybindings tab of the settings view. I was talking about the keybinding-resolver package that ships with Atom. Is that what you tried?


Backslash not working
#8

This is definitely the issue that @batjko mentioned:

If you look at the comment history, there are plenty of dupes … some that specifically mention \ on German keyboard layouts.


Sequential mappings with non-US keyboards
#9

Look UP the package “keyboard-localization”

Resolves the problem :smile:


#10

Until officially fixed, this’ll do the problem away quickly.