Cannot see my .log file in the folder tree


#1

I’m writing a MERN app and made my API streaming every request to a log file.
Surprisingly I cannot see the log file in the folder tree. I can open it with Atom by using the macOS finder.

If I open the same folder with sublimeText I have access to my log file.


#2

You’re unclear about what the file is. Is the extension .log or .js? Please share what you see in Atom’s tree view for the same folder. Is log.js or log/ in the .gitignore file? If you have the tree view package set to not show ignored files, anything under .gitignore will be invisible.


#3

I think I found out why, I have an other folder which is missing in my folder tree. The common point is : I gitignore them.

I still want to see them in my tree.

Also i’m using atom-material-ui theme https://atom.io/themes/atom-material-syntax and I would like to have the colored tree like in the example

@DamnedScholar : yes I miss the .log file

Here the example with ST.


#4

If you still want to see Git ignored files in the Tree View, then:

  1. Open Atom
  2. Launch the Settings View using Cmd+, on macOS or Ctrl+, on other platforms
  3. Click the Packages tab in the left-hand navigation bar
  4. Search for tree-view
  5. Uncheck “Hide VCS Ignored Files”