Cannot publish atom Package? npm ERR


#1

I am trying to publish a package for Atom with no success. On Linux, Manjaro (Arch), it fails completely. This is cause the atom in the aur repository has issues. So I cloned it to my Windows VM and try to publish from there.

I tried apm publish package and I get a general npm ERR. I have the newest Node and Atom installed fresh and it is not working when using that command from cmd.exe. I just installed an Ubuntu VM, installed atom, apm, npm, git, and nodejs fresh, and attempted to publish from there. But, I am getting the same error as in my Windows VM:

Saving token to Keychain ✓
Preparing and tagging a new version ✗
npm ERR! npm version [<newversion> | major | minor | patch | prerelease | preminor | premajor ]
npm ERR! 
npm ERR! (run in package dir)
npm ERR! 'npm -v' or 'npm --version' to print npm version (3.10.5)
npm ERR! 'npm view <pkg> version' to view a package's published version
npm ERR! 'npm ls' to inspect current package/dependency versions

#2

The syntax is apm publish [major|minor|patch]. So for example, you’ll probably want apm publish minor.
Major: Increases the version number in your package.json by 1.0.0. So if your package.json is 0.0.0 right now, apm publish major will publish version 1.0.0.
Minor: 0.1.0
Patch: 0.0.1

Here’s the documentation on publishing.


#3

Its a new package that is not on atom yet, and I have tried major, minor, patch, all with the same error.


#4

What command are you typing in exactly?


#5

I tried:

apm publish scaffolding

apm publish minor

apm publish major

#6
  1. Is the remote named origin?
  2. Is the branch named master?
  3. Are you trying to publish from the master branch? Or some other branch?

#7

Remote is origin/master: https://github.com/Drew-S/Scaffolding


#8

There aren’t any tags on the GitHub repository. Are tags being created on your local copy?


#9

I had tagging locally, yes, but I did notice that tagging was not on my github page after you mentioned it. I uploaded the tag and tried again. This time the publishing worked! Thanks for helping me find the problem.