Cannot Open Your Stylesheet in Linux


#1

Using v. 1.0.19 on Linux (Ubuntu 14.04.2 LTS). Selecting Edit > Open Your Stylesheet produces nothing. Other Open Your… menus work. Likewise, Ctr-Shf-P works for all other Open Your… commands except Open Your Stylesheet. I have styles.less where it should be (as pasted below). All the “Your” files in ~/.atom have same attributes.

EDIT: Found an explanation for this strange behavior. For whatever reason, I have a folder ~/atom:/.atom/stylesheet. AFAIU, some kind of project folder for Atom, but one I definitely didn’t create myself. (Why) should such a folder exist in the first place? Anyway, right-click and Show in File Manager on it gives Opening folder in File Manager failed; also, right-click and Delete does not accomplish anything. Right-click and Rename throws the following error. Anyway, if I rename it to e.g. ~/atom:/.atom/style in my file commander (midnight commander), Edit > Open Your Stylesheet works.

I have a few questions. What is ~/atom:? Should I delete it? Should I reinstall Atom?


/*

  • Your Stylesheet
  • This stylesheet is loaded when Atom starts up and is reloaded automatically
  • when it is changed and saved.
  • Add your own CSS or Less to fully customize Atom.
  • If you are unfamiliar with Less, you can read more about it here:
  • http://lesscss.org
    */

/*

  • Examples
  • (To see them, uncomment and save)
    */

// style the background color of the tree view
.tree-view {
// background-color: whitesmoke;
}

// style the background and foreground colors on the atom-text-editor-element itself
atom-text-editor {
// color: #333333; //w/ solarized-light (only)
// background-color: hsl(180, 24%, 12%);
}

// To style other content in the text editor’s shadow DOM, use the ::shadow expression
atom-text-editor::shadow .cursor {
// border-color: red;
}

atom-text-editor::shadow .variable.parameter.function.latex {
color: red;
}

atom-text-editor::shadow .variable.parameter.definition.latex {
color: yellow;
}


#2

I assume you mean ~/.atom. It holds your settings and packages. It never hurts to delete it but if you want to keep your packages and settings then restore the packages folder and all files not in a folder. The other folders can be deleted any time since they are caches.


#3

Nope, ~/atom:. All the full paths in my posts are exact as well


#4

Never heard of it. Someone else might be able to explain it. If I found it on my system I’d delete it. It might be created by some package but if so it’s a pretty lousy thing for a package to do.

Also, isn’t it bad to put a colon in a unix file name? Colons are used as file path separators in a number of places.


#5

True (I wouldn’t have used it myself (not to speak of adding the subdirectory tree .atom/stylesheet to it)). As said, I didn’t create it. For some reason, it persists in my treeview as some kind of project folder; e.g. right-click, Copy Project Path and paste yields atom:/.atom/style (after renaming)


#6

Have you tried turning of all your packages? Close all atom windows, delete the bad directory, and restart atom with atom --safe.


#7

When you execute “Open Your Stylesheet”, Atom executes the code:

atom.workspace.open("atom://.atom/stylesheet")

This URL is handled by a custom opener that then finds your stylesheet in the correct configuration directory and opens it. It looks like perhaps some package took the URL as the editor was being opened, corrupted it and created the file path.

I would delete the rogue directory. If it shows up again, I would try to track down what package is causing the issue.


#8

Sounds like a plausible explanation. I have made only minor changes to packages: installed one community package (language-latex) and disabled two core packages (spell-check and language-text); otherwise the package configuration should be as installed (a few days ago). I did what @mark_hahn suggested. After atom --safe, an empty file “style” still sits in the treeview and editor (although it shouldn’t exist anymore – I don’t see it in bash or midnight commander). Right-click, Copy Full Path yields atom:/.atom/style; Edit > Copy Path of the file in editor yields atom:/.atom/style/atom:/.atom/style/atom:/.atom/style/atom:/.atom/style. Right-click, delete in the treeview gives The root directory 'style' can't be removed. It doesn’t exist but persists atom’ically. I’ve tried atom --safe and atom a few times, “style” (both as a file and root directory) persists. Any suggestions? A reinstall?


#9

When you have weird state that persists like this, you can:

  1. Close all instances of Atom
  2. Move or delete the ~/.atom/storage directory
  3. Start Atom again

The weird state should be gone.


#10

How did you install the last time? In any case a reinstall never hurts. Use the deb file on the atom.io home page. Delete all atom crap in ~ of course.


#11

@leedohm: Did as told. It worked but if I Edit > Open Your Stylesheet, a new folder (or sth) is created in the treeview: atom://.atom/stylesheet. Once again, it doesn’t exist physically (yet) but… Rebooting and deleting ~/.atom/storage again resolves the issue, then Edit > Open Your Stylesheet re-creates it, exactly as before. Could be a bug but I should try reinstalling first. @mark_hahn: I used the atom.io deb file for installing


#12

OK, I removed atom, deleted ~/.atom, and reinstalled atom from the atom.io deb file. Immediately after the reinstall (before installing any packages), after Edit > Open Your Stylesheet, a folder or file stylesheet is created in the treeview. Copy-paste its full path (from context menu) shows atom://.atom/stylesheet. Every time I restart atom, no matter what files I had open in the previous session, stylesheet is in the treeview. Is this normal? I suppose it shouldn’t be. However, at least so far ~/atom://.atom/stylesheet hasn’t been created, so it’s a milder version of my initial plight (see the beginning of the thread). In short, this seems to be a bug. I’m using v. 1.2.3 on Ubuntu 14.04.2 LTS


#13

Since you’ve got consistent repro steps, please file a bug on https://github.com/atom/atom/issues so that we can track this. Sorry that you’re still having this issue :frowning: