Cannot install the 'Script' package


#1

Hello. I just got Atom a few days age, and love it, but I cannot install the ‘Script’ package. When I try, it just loads and comes back to the ‘Install’ button. I have tried using apm, but when I try to install the shell commands, The app tells me that they have been installed, but I cannot use them.


#2

What OS are you running?

Atom uses apm to install packages, so until the commands are installed, it can’t add packages.


#3

apm is installed along with Atom, the shell commands don’t need to be installed for it to work. They just make running apm and atom from the shell easy.


#4

So what’s the reason behind @suryanisaac’s issue? The directories for the executables change with each update. It seems more intuitive to me to have Atom invoke the apm command than to force it to execute the version under app-x.x.x.


#5

I am using macOS Sierra. Can it be a bug in the beta?


#6

What do you mean by “I cannot use them”? Do you get an error message? If so, what is it? Do you have /usr/local/bin in your PATH in your terminal?


#7

Atom has code to find apm, so it doesn’t need to use the apm shell command.

Except when you launch Atom, it can find things based on relative paths from the code that is currently executing. It doesn’t need to use absolute path stuff that would require it to route through app-x.x.x.


#8

/Library/Frameworks/Python.framework/Versions/3.6/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin

This is my path. Yes I get an error saying:

-bash: apm: command not found

#9

Do you have permissions to write to /usr/local/bin?


#10

Figured it out. I had some problem with Xcode and I fixed it. A huge thanks to @leedohm, @DamnedScholar :slight_smile:


#11

https://github.com/rgbkrk/atom-script/issues/1039 => try this