Cannot install platformio ide terminal 2.9.1 on atom

Dear team,
I get the following error message upon trying to install platformio ide terminal:

Installing “platformio-ide-terminal@2.9.1” failed.Hide output…

node-pty-prebuilt@0.7.6 install C:\Users\Shoai\AppData\Local\Temp\apm-install-dir-119623-3356-esr3t2.inoam\node_modules\platformio-ide-terminal\node_modules\node-pty-prebuilt
prebuild-install || node scripts/install.js

C:\Users\Shoai\AppData\Local\Temp\apm-install-dir-119623-3356-esr3t2.inoam\node_modules\platformio-ide-terminal\node_modules\node-pty-prebuilt>if not defined npm_config_node_gyp (node “C:\Users\Shoai\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild --build_v8_with_gn=false ) else (node “C:\Users\Shoai\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild --build_v8_with_gn=false )

prebuild-install WARN install No prebuilt binaries found (target=3.1.10 runtime=electron arch=x64 libc= platform=win32)
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at PythonFinder.failNoPython (C:\Users\Shoai\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:492:19)
gyp ERR! stack at PythonFinder. (C:\Users\Shoai\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:517:16)
gyp ERR! stack at C:\Users\Shoai\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:152:21)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command “C:\Users\Shoai\AppData\Local\atom\app-1.39.0\resources\app\apm\bin\node.exe” “C:\Users\Shoai\AppData\Local\atom\app-1.39.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild” “–build_v8_with_gn=false”
gyp ERR! cwd C:\Users\Shoai\AppData\Local\Temp\apm-install-dir-119623-3356-esr3t2.inoam\node_modules\platformio-ide-terminal\node_modules\node-pty-prebuilt
gyp ERR! node -v v8.9.3
gyp ERR! node-gyp -v v3.7.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\Shoai\AppData\Local\Temp\apm-install-dir-119623-3356-esr3t2.inoam\package.json’
npm WARN apm-install-dir-119623-3356-esr3t2.inoam No description
npm WARN apm-install-dir-119623-3356-esr3t2.inoam No repository field.
npm WARN apm-install-dir-119623-3356-esr3t2.inoam No README data
npm WARN apm-install-dir-119623-3356-esr3t2.inoam No license field.

npm ERR! errno 1
npm ERR! node-pty-prebuilt@0.7.6 install: prebuild-install || node scripts/install.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-pty-prebuilt@0.7.6 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Shoai.atom.apm_logs\2019-07-23T19_38_48_505Z-debug.log

1 Like

The same thing happened to me today. I opened Atom and all of a sudden the package was gone and when I tried to reinstall, it gave me this exact error. Somebody else suggested downgrading the package and Atom to 2.8.4 and respectively and I managed to do that for the package but not for Atom. This was such a great package before it completely crashed


it was a good package. its a shame, i cant get any other terminal to work either, either wont install on 1.39 or they are unresponsive with a blinking cursor so i had to go to c9

1 Like

Same for me

1 Like

I found sort of a solution. If you go to the GitHub repositories for earlier versions of atom, you can download version 1.38.2
Then, if go to your command prompt on WIndows, you can type in “apm install platformio-ide-terminal@2.8.4” to install the older version of platformio-ide-terminal. The two are now compatible. It works for me running Windows 10 64-bit. Make sure that you uncheck automatic updates in settings so that this doesn’t happen again, and wipe any existing copies of Atom off your computer before downloading 1.38.2. Hope this helps


This works! You must intall both atom and the IDE old versions. Thank you thank you.
I used this zip :
and thes instructions:[SOLVED] " Cannot find module '..\build\Release\pty.node' "

I use atom 1.39.0 and installed platformio-ide-terminal 2.8.4 and it still breaks.
If I start a new terminal (+ sign on the bottom line of the editor) then it pops up and does nothing.
I haven’t verified it but downgrading atom to 1.38.2 may be the solution.
Are there any hints to get atom@1.39.0 and platformio-ide-terminal@2.8.4 or even platformio-ide-terminal@2.9.1 running?

I’m having this same problem. Installed @2.8.4 but the terminal doesnt show anything

Same thing happened to me. While working with Atom yesterday evening serial montor suddenly stopped working. Tried to install the platformio ide terminal but got errors like the TS.
Now I have uninstalled Atom and are now wating for installation to complete, but it takes forverer. Waiting for “Atom dependencies”
I have a new i7 computer and a 200Mbit internet connection
Looking at my CPU it seems to be repeating the same thing over and over. (and no its not any other program)

Looking at my network connection it’s the same behaviour (and no it’s not any other program)
This is really frustrating as i am working on a project due on monday!

I don’t know what’s happening with your installation, but you don’t need to uninstall Atom to troubleshoot things (that’s kind of a drastic step). If you want to try a different version, just download the .zip file from the GitHub releases page and drop the folder anywhere on your computer. Then you’ll have a clean, non-updating version of Atom that you can run and have access to all of your packages.

The longer answer is that the native binaries for the packages that no longer work will need to be rebuilt (here’s the official word about it). You can wait for the package authors to push updates, or you can probably use apm rebuild from the command line in the folder of the affected package once you have the build pipeline for node-gyp correctly configured. Obviously that’s the long-term solution that might require you to learn new things, so you should go for the short-term solution of running an old version of Atom.

Thank you. I downloadedan an older version, disconnected Internet, installed, disabled automatic updates, reconnected Internet and now it’s working.

This is working for me Thanks!!

I created a .zip of the working IDE and old Atom version. Github wont take files over 25M and its 116M. Im happy to send people copies or a dropbox link. Let me know if theres osme webspace I can leave it for everyone.

I believe having a dropbox link would be a better way to do it.