Cannot install packages with 1.0.3?


#1

I just got the update for Atom 1.0.3 on Windows 7, and I tried installing a package, and it failed.

I deleted the previous install to try running a clean install, but still getting failure errors.

Anyone else having problems with 1.0.3 installing packages?


#2

This is the current error message. I never had this issue previously, so I don’t know what has changed.

Installing “language-puppet@0.13.0” failed.Hide output…

gyp info it worked if it ends with ok
gyp info using node-gyp@1.0.2
gyp info using node@0.10.35 | win32 | ia32
gyp http GET https://atom.io/download/atom-shell/v0.22.0/node-v0.22.0.tar.gz
gyp WARN install got an error, rolling back install
gyp
Compiler tools not found
Packages that depend on modules that contain C/C++ code will fail to install.
Read here for instructions on installing Python and Visual Studio.
Run apm install --check after installing to test compiling a native module.


#3

Do you have python and visual studio installed? This package needs them. Have you ever installed this package before?

Are you running as administrator? You will have to use different install instructions, which I can give here, if you are.


#4

I have been using Atom for a number of versions, and I had a number of packages install perfectly fine before now.

I got an error trying to update ex-mode (it was complaining something about package.json).

I decided to try a fresh install. Regardless now whether I run the install as administrator or as a normal user, every package I try to install gives the same failure about compiling tools.

What would have changed that suddenly requires me to need Python and Visual Studio just to install the minimap package???

minimap fails with this error
vim-mode fails with this error
ex-mode fails with this error

Tried installing 1.0.2 again. Tried to install Minimap again, got pointed to the error https://github.com/atom/settings-view/issues/604

Is it the fix for issue 604 that is broken?


#5

Have you tried installing these packages from the command line using apm install?


#6

Same error about Node

C:\Windows\System32>apm install minimap
Installing minimap to C:\Users\user\.atom\packages
gyp info it worked if it ends with ok
gyp info using node-gyp@1.0.2
gyp info using node@0.10.35 | win32 | ia32
gyp http GET https://atom.io/download/atom-shell/v0.22.0/node-v0.22.0.tar.gz
gyp WARN install got an error, rolling back install
gyp

I can manually download the Node file https://atom.io/download/atom-shell/v0.22.0/node-v0.22.0.tar.gz and I can open it to see the src contents, so I don’t see that as being the problem for the error.

[EDIT] I do also have Microsoft Visual C++ Redistributable packages installed, if it is trying to use those?


#7

@abe, any ideas why this is all of a sudden a problem?


#8

Actually, you didn’t answer any of my questions. I’ll repeat them here …


#9

Python & Visual Studio?
No, I don’t require either of those.

Installed the package before?
Yes, I have previously been using packages with no errors whatsoever until now. From version 0.209 or so onwards I have been using vim-mode, ex-mode, and more recently as of 1.0 I started using minimap, minimap-find-and-replace, minimap-selection, and a number of UI theme and Syntax theme packages.

Am I running as Administrator?
No, I escalate privileges to install applications as a local administrator if required, but Atom install was done without thoes permissions and had no visible errors during the install process.

In regards to trying to get a “clean install” for 1.0.3 and reinstalling 1.0.2, I deleted directories C:\Users\user\.atom and C:\Users\user\AppData\Local\atom each time, but this hasn’t helped.
If there is something else I can try to clean up the install and start again, please let me know.


#10

Are you behind a proxy? It seems that under some circumstances you can get the same error when you’re behind a proxy but don’t have your proxy settings configured for Atom:

See here for instructions on how to configure your proxy settings:


#11

I had a read of that and I don’t see how it’s related?

My error message is missing compiler tools. That issue is about parse errors due to failed connections.

It is much similar to these closed issues:

Also this might help?


#12

So can I take that as an answer that you are not behind a proxy?


#13

For brevity sake, no.

Perhaps an image will make the issue clearer:

https://atom.io/docs/v0.186.0/build-instructions/windows

Why do I need to install any of those things to install Atom packages?


#14

Some Atom packages require native code to perform well, in other words C/C++ code. On Windows, those are the tools that Atom is configured to use in order to properly install packages with those dependencies.


#15

So in the update somewhere between 1.0.2 and 1.0.3 Atom has gone from requiring zero of those things to requiring all of them to be installed?

Is that serious?


#16

Not to my knowledge. That’s why I was asking other questions.


#17

The only other thing I have tried recently was to run vim-mode using development package.

I ran the apm unlink -d command a number of times before removing all the packages. That is why I tried a clean install after the package update failed the first time.

Is it possible that has still has a setting somewhere I have missed that I need to kill?

The git location no longer exists.


#18

I don’t know for the other packages, but the minimap doesn’t require any native libs, so node-gyp shouldn’t be involved. Except if one of its dependencies now use one, but it doesn’t seems so.


#19

@abe Definitely looks like something in there does need it?

Is that path current? Why is it trying to download node from an old “atom-shell” directory?

[quote=“ardrigh, post:6, topic:19395”][EDIT] I do also have Microsoft Visual C++ Redistributable packages installed, if it is trying to use those?
[/quote]

There’s a whole bunch of different VC++ Redistributables. Most common is still the 2010 one, but it does depend on the package and its own dependencies.


#20

I just reviewed all the dependencies of the minimap and I’m pretty certain that there’s nothing in there that need gyp.

Actually running apm install in a package with no dependencies at all still load gyp:

> apm install --verbose
gyp info it worked if it ends with ok
gyp verb cli [ '/Applications/Atom.app/Contents/Resources/app/apm/bin/node',
gyp verb cli   '/Applications/Atom.app/Contents/Resources/app/apm/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js',
gyp verb cli   'install',
gyp verb cli   '--target=0.22.0',
gyp verb cli   '--dist-url=https://atom.io/download/atom-shell',
gyp verb cli   '--arch=x64',
gyp verb cli   '--ensure',
gyp verb cli   '--verbose' ]
gyp info using node-gyp@1.0.2
gyp info using node@0.10.35 | darwin | x64
gyp verb command install []
gyp verb install input version string "0.22.0"
gyp verb install installing version: 0.22.0
gyp verb install --ensure was passed, so won't reinstall if already installed
gyp verb install version is already installed, need to check "installVersion"
gyp verb got "installVersion" 9
gyp verb needs "installVersion" 9
gyp verb install version is good
0.22.0
gyp info ok
Installing modules âś“

So, I believe that it’s apm itself that call it during startup and that @ardrigh issue is likely due to a deeper problem in how his Atom version was installed. Sadly, it’s been years now that I left the windows world so I can provide no help beyond that.