Cannot install on Mac OS 10.10.5


#1

I have been trying for hours to get atom to install. I can download the zip file, but nothing happens when I try to expand it with Archive Utility. Tried looking for atom from Terminal with “which atom” but it does not respond with anything but a command prompt.

I even turned off my security for downloads in Prefs (scary!). I re-downloaded the atom-mac.zip again and still no install.

This is my first time here and I’m not a programmer, so please be kind if I am asking something you all think is very basic. :slight_smile:

I intend to use atom with the Jibo SDK, if I can ever get it to work. Already have successfully installed node-v4.4.5.

Thanks for any help you can offer.


#2

So what happens when you double-click the zip file after you’ve downloaded it from the website at https://atom.io?


#3

One of two things happens when I double click atom-mac.zip:

  • It twitches (the way it does when you double click a zip file and it opens) but absolutely nothing else happens, i.e. does not open
  • It twitches and creates a file: atom-mac.zip.cpgz If I double click this file, it twitches and then I get a file called atom-mac(1) 2.zip, that looks to me like another copy of the original zip file.

Also, not always, but a few times when I downloaded the zip file, a file called atom-mac.zip.part also appears. I’ve tried opening the “part” file, nothing happens.


#4

Where did you download the file from and using which browser?

I just tried downloading it from the button on https://atom.io and it unzipped fine when double-clicking. Though I am using Mac OS X 10.11.5.


#5

This is a temporary file that stores data about the download in progress. If it doesn’t disappear, this indicates that the download was canceled or stalled out. This matches the information I get when Googling .cpgz, so it seems most likely that the file never once downloaded completely and you’ve been clicking on incomplete data.

You could try building from source.


#6

Before I did anything else today, I did a restart on my Mac. Tried it once yesterday, to no effect.

Never say never, I told myself… I double-clicked the atom zip and voila! It expanded!

I’m so embarrassed now that I didn’t keep fiddling around myself without reaching out for help.

Thank you all so much for your patient and thoughtful assistance. I really appreciate your support.

Blushing,
Juk


#7

You’re very welcome. I’m glad things are working for you now :grinning: