Cannot install anything after trying full atom reinstallation


#1

Hello,

After using atom for awhile, I decided to clean up some space in my laptop. And I also removed atom, but now I wanted to install it back. However, after reinstalling, I keep on getting “tunneling socket could not be established, cause=connect ECONNREFUSED 127.0.0.1:80”

Is there any possible fix to this? I’ve browsed through some topics yet haven’t really gotten it to work. It was working before (Probably 3 months ago since i used atom)

EDIT: Current issue is still not solved. Was not able to find an answer, so as of now I’m doing manual install on my packages.

Thank you

  • Daniel

#2

From the error message it sounds like you’ve got a proxy configuration that is messed up. Have you checked out the proxy configuration information in the Installation section of the Atom Flight Manual?


#3

Is proxy a requirement to Atom packages? I remember before I didn’t touch anything but install git and atom and it works.
Hmm, interesting, I’ll see what I can do as I’m not familiar with this proxy stuff.

Thanks again :slight_smile:


#4

No, it isn’t … but if you have a proxy configuration and no proxy, that could be a problem :grinning:


#5

I still cannot get it to work, I’ve done the following commands in cmd
npm config rm proxy
npm config rm https-proxy
I’ve also tried disabling ESET smart security to see if it is because of its firewall, but it doesn’t appear to be so. And I do not have any proxy running (I don’t think)

Any other option to resolve this issue?

Thanks for your help :yum:


#6

Did you try the apm config versions of those same commands?


#7

Yes, I first tried it with apm config version then I went on searching again and found npm. So i tried both, but none of the method is working unfortunately.

Thanks


#8

I don’t know why it would be trying to connect to 127.0.0.1 then, that’s generally either a proxy or a firewall configuration.


#9

Alright, thank you very much. I’ll continue to do some research on this to see if I can resolve it. I’ll post my solution if I could find one.


#10

Sorry for bringing this up again. As time have passed by, and I still got hooked back into Atom text editor. Yet, I’m still unable to solve this issue tunneling socket could not be established, cause=connect ECONNREFUSED 127.0.0.1:80 no matter how many times I reinstall atom, it won’t change anything. I’ve also restarted a couple of time, and none of it works.


#11

Have you tried running apm config list to see if there is anything in there that might be causing the problem?


#12

I don’t see anything that could affect Atom. Sorry for the really late reply, I didn’t set email notification so ._.

; cli configs
user-agent = "npm/3.10.8 node/v6.9.1 win32 x64"

; userconfig C:\Users\danie\.npmrc
registry = "http://registry.npmjs.org/"
strict-ssl = false

; builtin config undefined
prefix = "C:\\Users\\danie\\AppData\\Roaming\\npm"

; node bin location = C:\Program Files\nodejs\node.exe
; cwd = C:\Users\danie
; HOME = C:\Users\danie
; "npm config ls -l" to show all defaults.

#13

Did you run Apm config list or Npm config list? Because that looks like npm config list based on the user-agent value.


#14

Oops, did not know that its two different thing.

; cli configs
globalconfig = "C:\\Users\\danie\\.atom\\.apm\\.apmrc"
user-agent = "npm/3.10.5 node/v4.4.5 win32 ia32"
userconfig = "C:\\Users\\danie\\.atom\\.apmrc"

; environment configs
node-gyp = "C:\\Users\\danie\\AppData\\Local\\atom\\app-1.12.7\\resources\\app\\apm\\bin\\\\..\\node_modules\\node-gyp\\bin\\node-gyp.js"

; globalconfig C:\Users\danie\.atom\.apm\.apmrc
cache = "C:\\Users\\danie\\.atom\\.apm"
progress = false

; node bin location = C:\Users\danie\AppData\Local\atom\app-1.12.7\resources\app\apm\bin\node.exe
; cwd = C:\Users\danie
; HOME = C:\Users\danie
; "npm config ls -l" to show all defaults.

#15

Yeah, I’m not seeing anything in there that looks any different than what I’ve got. I have no idea why it would be trying to connect to itself.


#16

Strange :frowning: Maybe I should do a full reset on my computer soon. It was working like 6 months ago…
Maybe that will fix it :confused: